aboutsummaryrefslogtreecommitdiff
path: root/client/helloworld/meson.build
diff options
context:
space:
mode:
authorTrumeet <yuuta@yuuta.moe>2022-07-29 11:56:55 -0700
committerTrumeet <yuuta@yuuta.moe>2022-07-29 11:56:55 -0700
commitff769a117046448dec8f09d86dfc661cda0bbc3b (patch)
tree850712959b05d988994cb1d40d85511e10651fd7 /client/helloworld/meson.build
parent41d27344c3b489466632bd2f1314fd69ff0a363c (diff)
downloadacron-ff769a117046448dec8f09d86dfc661cda0bbc3b.tar
acron-ff769a117046448dec8f09d86dfc661cda0bbc3b.tar.gz
acron-ff769a117046448dec8f09d86dfc661cda0bbc3b.tar.bz2
acron-ff769a117046448dec8f09d86dfc661cda0bbc3b.zip
build(helloworld): switch to Meson
Diffstat (limited to 'client/helloworld/meson.build')
-rw-r--r--client/helloworld/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/client/helloworld/meson.build b/client/helloworld/meson.build
new file mode 100644
index 0000000..73832e2
--- /dev/null
+++ b/client/helloworld/meson.build
@@ -0,0 +1,26 @@
+project('helloworld', 'c',
+ version : '1.0',
+ license : 'GPL-2.0-only')
+
+xtra_link_args = []
+xtra_c_args = [ '-D_POSIX_C_SOURCE=200809L' ]
+if get_option('debug') == true
+ xtra_c_args += '-DDEBUG'
+endif
+
+libac_dep = dependency('ac',
+ fallback : ['libacron', 'libac_dep'],
+ default_options: [ 'default_library=static' ]
+)
+
+sources = [
+ 'net.c',
+ 'main.c'
+]
+
+executable('helloworld', sources,
+ dependencies : [ libac_dep ],
+ link_args : xtra_link_args,
+ c_args : xtra_c_args,
+ install : true
+)