aboutsummaryrefslogtreecommitdiff
path: root/client/helloworld/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'client/helloworld/meson.build')
-rw-r--r--client/helloworld/meson.build26
1 files changed, 26 insertions, 0 deletions
diff --git a/client/helloworld/meson.build b/client/helloworld/meson.build
new file mode 100644
index 0000000..73832e2
--- /dev/null
+++ b/client/helloworld/meson.build
@@ -0,0 +1,26 @@
+project('helloworld', 'c',
+ version : '1.0',
+ license : 'GPL-2.0-only')
+
+xtra_link_args = []
+xtra_c_args = [ '-D_POSIX_C_SOURCE=200809L' ]
+if get_option('debug') == true
+ xtra_c_args += '-DDEBUG'
+endif
+
+libac_dep = dependency('ac',
+ fallback : ['libacron', 'libac_dep'],
+ default_options: [ 'default_library=static' ]
+)
+
+sources = [
+ 'net.c',
+ 'main.c'
+]
+
+executable('helloworld', sources,
+ dependencies : [ libac_dep ],
+ link_args : xtra_link_args,
+ c_args : xtra_c_args,
+ install : true
+)