aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2017-07-08 12:26:45 +0200
committerNikolaus Rath <Nikolaus@rath.org>2017-07-08 12:26:45 +0200
commit82e899fb21c116fa8303cabbc10d68bfa06fc89f (patch)
tree52c3883ca6144aca3c515b92fb86eddce82b5775 /meson.build
parent34146444ce20c477cba7e9fe113e4387da32ae94 (diff)
downloadsshfs-82e899fb21c116fa8303cabbc10d68bfa06fc89f.tar
sshfs-82e899fb21c116fa8303cabbc10d68bfa06fc89f.tar.gz
sshfs-82e899fb21c116fa8303cabbc10d68bfa06fc89f.tar.bz2
sshfs-82e899fb21c116fa8303cabbc10d68bfa06fc89f.zip
Switch to libfuse 3.1.0
libfuse 3.0.0 is rather new and not widely used yet, so requiring libfuse 3.1.0 right away shouldn't be a problem.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 075446a..d4a96ea 100644
--- a/meson.build
+++ b/meson.build
@@ -45,14 +45,14 @@ configure_file(input: 'sshfs.1.in',
configure_file(output: 'config.h',
configuration : cfg)
-sshfs_deps = [ dependency('fuse3', version: '>= 3.0.0'),
+sshfs_deps = [ dependency('fuse3', version: '>= 3.1.0'),
dependency('glib-2.0'),
dependency('gthread-2.0') ]
executable('sshfs', sshfs_sources,
include_directories: include_dirs,
dependencies: sshfs_deps,
- c_args: ['-DFUSE_USE_VERSION=30'],
+ c_args: ['-DFUSE_USE_VERSION=31'],
install: true,
install_dir: get_option('bindir'))