summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/configuration.nix b/configuration.nix
new file mode 100644
index 0000000..c70a6ec
--- /dev/null
+++ b/configuration.nix
@@ -0,0 +1,64 @@
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [
+ ./hardware-configuration.nix
+ ./local.nix
+ ./domain.nix
+ ./desktop.nix
+ ];
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ nixpkgs.config.allowUnfree = true;
+
+ services.btrfs.autoScrub.enable = true;
+ services.btrfs.autoScrub.fileSystems = [ "/" ];
+
+ boot.loader.efi.canTouchEfiVariables = false;
+ boot.loader.efi.efiSysMountPoint = "/efi";
+ boot.loader.grub.efiInstallAsRemovable = true;
+ boot.loader.grub.device = "nodev";
+ boot.loader.grub.efiSupport = true;
+
+ # powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+ hardware.cpu.intel.updateMicrocode = true;
+ hardware.cpu.amd.updateMicrocode = true;
+
+ time.timeZone = "America/Vancouver";
+
+ systemd.oomd.enable = false;
+ security.polkit.enable = lib.mkForce false;
+
+ environment.systemPackages = with pkgs; [
+ vim
+ llvm
+ file
+ tmux
+ gnumake
+ bmake
+ git
+ gcc12
+ binutils
+ wine
+ vmware-workstation
+ ];
+
+ services.cron.enable = true;
+
+ services.openssh.enable = true;
+ services.openssh.permitRootLogin = "yes";
+
+ services.vnstat.enable = true;
+
+ system.copySystemConfiguration = true;
+
+ # This value determines the NixOS release from which the default
+ # settings for stateful data, like file locations and database versions
+ # on your system were taken. It‘s perfectly fine and recommended to leave
+ # this value at the release version of the first install of this system.
+ # Before changing this value read the documentation for this option
+ # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
+ system.stateVersion = "22.11"; # Did you read the comment?
+}
+