summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTrumeet <yuuta@yuuta.moe>2022-10-22 14:19:32 -0700
committerTrumeet <yuuta@yuuta.moe>2022-10-22 14:19:32 -0700
commit57bd18ef88e48c18abf156b2635675df56c4a67e (patch)
tree799051ed279430013833078b976ec1eb2d9c376b /CMakeLists.txt
parentc03e43f9bc38133f88fb93078e634b105e4a0600 (diff)
downloadksyxbot-57bd18ef88e48c18abf156b2635675df56c4a67e.tar
ksyxbot-57bd18ef88e48c18abf156b2635675df56c4a67e.tar.gz
ksyxbot-57bd18ef88e48c18abf156b2635675df56c4a67e.tar.bz2
ksyxbot-57bd18ef88e48c18abf156b2635675df56c4a67e.zip
Use version number as TDLib config version
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index deede86..380cb42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,8 @@ project(ksyxbot VERSION 1.0 LANGUAGES C CXX)
set(CMAKE_C_STANDARD 99)
+configure_file(config.h.in config.h)
+
IF (CMAKE_BUILD_TYPE MATCHES Debug)
add_compile_definitions(TD_USE_ASAN)
ENDIF (CMAKE_BUILD_TYPE MATCHES Debug)