aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index e30b75c..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,33 +0,0 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ([2.71])
-AC_INIT(minebridge, 1.0, yuuta@yuuta.moe)
-AM_INIT_AUTOMAKE([-Wall -Werror subdir-objects])
-AC_CONFIG_SRCDIR([config.h.in])
-AC_CONFIG_HEADERS([config.h])
-
-# Checks for programs.
-AC_PROG_CC
-
-# Checks for libraries.
-AC_CHECK_LIB([curl], [curl_easy_init])
-AC_CHECK_LIB([json-c], [json_object_put])
-AC_CHECK_LIB([pthread], [pthread_create])
-
-# Checks for header files.
-AC_CHECK_HEADERS([libintl.h netdb.h sys/socket.h unistd.h inttypes.h stdint.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_TYPE_INT32_T
-AC_TYPE_INT64_T
-AC_TYPE_UINT64_T
-AC_TYPE_UINT32_T
-AC_TYPE_SIZE_T
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
-AC_CHECK_FUNCS([memset regcomp socket strerror strtoumax])
-
-# Checks for library functions.
-AC_CONFIG_FILES([Makefile])
-AC_OUTPUT