aboutsummaryrefslogtreecommitdiff
path: root/client/libacron/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/libacron/CMakeLists.txt')
-rw-r--r--client/libacron/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/client/libacron/CMakeLists.txt b/client/libacron/CMakeLists.txt
index 223b259..c87063e 100644
--- a/client/libacron/CMakeLists.txt
+++ b/client/libacron/CMakeLists.txt
@@ -89,18 +89,19 @@ target_link_libraries(ac ${LIBAC_DEPS})
target_include_directories(ac-static PUBLIC ${LIBAC_INCLUDES})
target_link_libraries(ac-static ${LIBAC_DEPS})
-add_executable(acronc
- acronc/main.c
- acronc/net.c
- acronc/net.h)
+add_executable(helloworld
+ apps/helloworld/main.c
+ apps/helloworld/net.c
+ apps/helloworld/net.h
+ )
if(WIN32)
set(ACRONC_DEPS ws2_32)
endif()
set(ACRONC_DEPS ${ACRON_DEPS} ac)
-target_link_libraries(acronc ac)
-target_include_directories(acronc PUBLIC "${PROJECT_BINARY_DIR}" include/)
+target_link_libraries(helloworld ac)
+target_include_directories(helloworld PUBLIC "${PROJECT_BINARY_DIR}" include/)
-install(TARGETS ac ac-static acronc
+install(TARGETS ac ac-static helloworld
EXPORT ${PROJECT_NAME}-targets
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}