aboutsummaryrefslogtreecommitdiff
path: root/client/libacron/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/libacron/CMakeLists.txt')
-rw-r--r--client/libacron/CMakeLists.txt27
1 files changed, 1 insertions, 26 deletions
diff --git a/client/libacron/CMakeLists.txt b/client/libacron/CMakeLists.txt
index 57ce521..57da4af 100644
--- a/client/libacron/CMakeLists.txt
+++ b/client/libacron/CMakeLists.txt
@@ -89,32 +89,7 @@ target_link_libraries(ac ${LIBAC_DEPS})
target_include_directories(ac-static PUBLIC ${LIBAC_INCLUDES})
target_link_libraries(ac-static ${LIBAC_DEPS})
-# Apps
-if(WIN32)
- set(APPS_DEPS ws2_32)
-endif()
-set(APPS_DEPS ${APPS_DEPS} ac)
-
-# apps/helloworld
-add_executable(helloworld
- apps/helloworld/main.c
- apps/helloworld/net.c
- apps/helloworld/net.h
- )
-target_link_libraries(helloworld ${APPS_DEPS})
-target_include_directories(helloworld PUBLIC "${PROJECT_BINARY_DIR}" include/)
-
-# apps/acronc
-add_executable(acronc
- apps/acronc/main.c
- apps/acronc/common.h
- apps/acronc/log.h
- apps/acronc/log.c
- apps/acronc/handler.h apps/acronc/handler_signal.c apps/acronc/config.c apps/acronc/config.h apps/acronc/client.c apps/acronc/client.h apps/acronc/handler_stdin.c apps/acronc/helpers.c apps/acronc/helpers.h apps/acronc/handler_socket.c apps/acronc/async_dns.c)
-target_link_libraries(acronc ${APPS_DEPS} uv)
-target_include_directories(acronc PUBLIC "${PROJECT_BINARY_DIR}" include/)
-
-install(TARGETS ac ac-static helloworld acronc
+install(TARGETS ac ac-static
EXPORT ${PROJECT_NAME}-targets
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}