aboutsummaryrefslogtreecommitdiff
path: root/client/applets/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'client/applets/meson.build')
-rw-r--r--client/applets/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/client/applets/meson.build b/client/applets/meson.build
new file mode 100644
index 0000000..b89b9dc
--- /dev/null
+++ b/client/applets/meson.build
@@ -0,0 +1,21 @@
+project('acron-applets', 'c',
+ version : '1.0',
+ license : 'GPL-2.0-only')
+
+xtra_link_args = []
+xtra_c_args = [ '-D_POSIX_C_SOURCE=200809L' ]
+if get_option('debug') == true
+ xtra_c_args += '-DDEBUG'
+endif
+
+libac_dep = dependency('ac',
+ fallback : ['libacron', 'libac_dep'],
+ default_options: [ 'default_library=static' ]
+)
+
+executable('here', [ 'applet.c', 'here.c' ],
+ dependencies : [ libac_dep ],
+ link_args : xtra_link_args,
+ c_args : xtra_c_args,
+ install : true
+)