aboutsummaryrefslogtreecommitdiff
path: root/client/acronc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'client/acronc/meson.build')
-rw-r--r--client/acronc/meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/client/acronc/meson.build b/client/acronc/meson.build
new file mode 100644
index 0000000..a143905
--- /dev/null
+++ b/client/acronc/meson.build
@@ -0,0 +1,37 @@
+project('acronc', 'c',
+ version : '1.0',
+ license : 'GPL-2.0-only')
+
+xtra_link_args = []
+xtra_c_args = [ '-D_POSIX_C_SOURCE=200809L' ]
+if get_option('debug') == true
+ xtra_c_args += '-DDEBUG'
+endif
+
+libac_dep = dependency('libac',
+ fallback : ['libacron', 'libac_dep'],
+ default_options: [ 'default_library=static' ]
+)
+libuv_dep = dependency('libuv',
+ fallback : ['libuv', 'libuv_dep'],
+ default_options: [ 'default_library=static' ]
+)
+
+acronc_sources = [
+ 'async_dns.c',
+ 'client.c',
+ 'config.c',
+ 'handler_signal.c',
+ 'handler_socket.c',
+ 'handler_stdin.c',
+ 'helpers.c',
+ 'log.c',
+ 'main.c'
+]
+
+executable('acronc', acronc_sources,
+ dependencies : [ libac_dep, libuv_dep ],
+ link_args : xtra_link_args,
+ c_args : xtra_c_args,
+ install : true
+)