aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/sysv4/solaris2/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/sysv/sysv4/solaris2/configure.in')
-rw-r--r--sysdeps/unix/sysv/sysv4/solaris2/configure.in33
1 files changed, 33 insertions, 0 deletions
diff --git a/sysdeps/unix/sysv/sysv4/solaris2/configure.in b/sysdeps/unix/sysv/sysv4/solaris2/configure.in
new file mode 100644
index 0000000000..1c02fbb499
--- /dev/null
+++ b/sysdeps/unix/sysv/sysv4/solaris2/configure.in
@@ -0,0 +1,33 @@
+sinclude(./aclocal.m4)dnl Autoconf lossage
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+# Local configure fragment for sysdeps/unix/sysv/sysv4/solaris2
+
+# Concensus on stdio is that it's broken.
+test $stdio = default && stdio=libio
+
+# Crypt is your friend.
+case $add_ons in
+ *crypt*)
+ message=
+ ;;
+ *)
+ message="\
+*** WARNING:
+*** Are you sure you do not want to use the \`crypt' add-on?"
+ ;;
+esac
+
+if test "$message"; then
+ if test $enable_sanity = yes; then
+ echo "\
+*** You should not compile the GNU libc without the \`crypt' add-on.
+*** Not using them risks to be incompatible with the libraries of
+*** other systems. Consider getting the add-on and restart the
+*** configuration.
+*** If you reall mean to avoid this add-on run configure again, now
+*** using the extra parameter \`--disable-sanity-checks'."
+ exit 1
+ else
+ echo "$message"
+ fi
+fi