aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index 94c4361540..4f116b57cb 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -112,16 +112,17 @@ if test $host = $build; then
ac_prefix=$ac_default_prefix
fi
AC_MSG_CHECKING([for symlinks in ${ac_prefix}/include])
+ ac_message=
if test -L ${ac_prefix}/include/net; then
- message=" ${ac_prefix}/include/net is a symlink"
+ ac_message="$ac_message
+ ${ac_prefix}/include/net is a symlink"
fi
if test -L ${ac_prefix}/include/scsi; then
- message="$message
+ ac_message="$ac_message
${ac_prefix}/include/scsi is a symlink"
fi
- if test -n "$message"; then
- AC_MSG_ERROR([
-$message
+ if test -n "$ac_message"; then
+ AC_MSG_ERROR([$ac_message
\`make install' will destroy the target of the link(s).
Delete the links and re-run configure, or better still, move the entire
${ac_prefix}/include directory out of the way.])