aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index dfae5a1de3..709d8e913f 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -41,6 +41,11 @@ fi
case "$machine" in
alpha*)
arch_minimum_kernel=2.1.100
+ libc_cv_gcc_unwind_find_fde=yes
+ ;;
+ i386*)
+ libc_cv_gcc_unwind_find_fde=yes
+ arch_minimum_kernel=2.0.10
;;
ia64*)
arch_minimum_kernel=2.4.0
@@ -50,9 +55,19 @@ case "$machine" in
;;
mips*)
arch_minimum_kernel=2.2.15
+ libc_cv_gcc_unwind_find_fde=yes
+ ;;
+ powerpc)
+ libc_cv_gcc_unwind_find_fde=yes
+ arch_minimum_kernel=2.0.10
;;
sh*)
arch_minimum_kernel=2.3.99
+ libc_cv_gcc_unwind_find_fde=yes
+ ;;
+ sparc*)
+ libc_cv_gcc_unwind_find_fde=yes
+ arch_minimum_kernel=2.0.10
;;
x86_64*)
arch_minimum_kernel=2.4.0
@@ -96,6 +111,12 @@ eat flaming death
fi
fi
+# The result of the above test for the use of the FDE code is invalid if
+# the user overrides the decision about the minimum ABI.
+if test "$oldest_abi" != default && test "2.2.4" \< "$oldest_abi"; then
+ libc_cv_gcc_unwind_find_fde=no
+fi
+
if test -n "$sysheaders"; then
CPPFLAGS=$OLD_CPPFLAGS
fi