aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/unix/configure.in')
-rw-r--r--sysdeps/unix/configure.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/sysdeps/unix/configure.in b/sysdeps/unix/configure.in
index 6d8a1fd006..74456fe18c 100644
--- a/sysdeps/unix/configure.in
+++ b/sysdeps/unix/configure.in
@@ -72,7 +72,7 @@ for unix_function in \
getitimer setitimer \
getdomainname/getdomain=bsd/bsd4.4 \
setdomainname/setdomain=bsd/bsd4.4 \
- profil=bsd \
+ profil=bsd readv=bsd writev=bsd \
getpriority setpriority \
getrlimit setrlimit
do
@@ -85,7 +85,7 @@ do
eval "unix_syscall=`echo $unix_function | \
sed -e 's@=\(.*\)$@ unix_srcdir=\1@' \
-e 's@/\(.*\)$@ unix_srcname=\1@'`"
- test -z "$unix_srcname" && unix_srcname=$unix_function
+ test -z "$unix_srcname" && unix_srcname=$unix_syscall
unix_implementor=none
for unix_dir in $sysnames; do
@@ -97,11 +97,13 @@ do
fi
done
- # mkdir and rmdir have implementations in unix/sysv, but
- # the simple syscall versions are preferable if available.
- test $unix_syscall = mkdir -o $unix_syscall = rmdir && \
- test $unix_implementor = unix/sysv && \
- unix_implementor=generic
+ case $unix_syscall in
+ mkdir|rmdir)
+ # mkdir and rmdir have implementations in unix/sysv, but
+ # the simple syscall versions are preferable if available.
+ test $unix_implementor = unix/sysv && unix_implementor=generic
+ ;;
+ esac
case $unix_implementor in
none|stub|generic|posix)