aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 14 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index 6cbcf0e046..8f0df5c7c1 100644
--- a/configure.in
+++ b/configure.in
@@ -636,27 +636,6 @@ test -n "$aux_missing" && AC_MSG_WARN([
CCVERSION=`$CC -v 2>&1 | sed -n 's/gcc version //p'`
AC_SUBST(CCVERSION)
-case $CCVERSION in
- 3.*) gcc3=yes;;
-esac
-
-if test x"$gcc3" = xyes; then
- echo "\
-*** This version of GNU libc cannot be compiled by GCC 3.x.
-*** GCC 3.x will generate a library that is binary incompatible to
-*** older and future releases of GNU libc.
-*** You should compile this GNU libc release by an older GCC version
-*** or wait for the next GNU libc release."
- if test $enable_sanity = yes; then
- echo "\
-*** If you really mean to use GCC 3.x, run configure again
-*** using the extra parameter \`--disable-sanity-checks'."
- exit 1
- else
- echo "\
-*** This configuration is not supported by the GNU libc developers."
- fi
-fi
# if using special system headers, find out the compiler's sekrit
# header directory and add that to the list. NOTE: Only does the right
# thing on a system that doesn't need fixincludes. (Not presently a problem.)
@@ -713,6 +692,14 @@ AC_MSG_ERROR([
*** and run configure again.])
fi
+AC_CACHE_CHECK(whether GCC supports -static-libgcc, libc_cv_gcc_static_libgcc, [dnl
+if $CC -v -static-libgcc 2>&1 | grep -q 'unrecognized option.*static-libgcc'; then
+ libc_cv_gcc_static_libgcc=
+else
+ libc_cv_gcc_static_libgcc=-static-libgcc
+fi])
+AC_SUBST(libc_cv_gcc_static_libgcc)
+
AC_PATH_PROG(BASH, bash, no)
if test "$BASH" != no &&
$BASH -c 'test "$BASH_VERSINFO" \
@@ -1459,6 +1446,7 @@ libc_link_sources=
use_ldconfig=no
ldd_rewrite_script=no
libc_cv_sysconfdir=$sysconfdir
+libc_cv_gcc_unwind_find_fde=no
# Iterate over all the sysdep directories we will use, running their
# configure fragments, and looking for a uname implementation.
@@ -1484,6 +1472,11 @@ for dir in $sysnames; do
]dnl
done
+if test x$libc_cv_gcc_unwind_find_fde = xyes; then
+ AC_DEFINE(EXPORT_UNWIND_FIND_FDE)
+fi
+AC_SUBST(libc_cv_gcc_unwind_find_fde)
+
AC_LINK_FILES(`echo $libc_link_sources`, `echo $libc_link_dests`)
# If we will use the generic uname implementation, we must figure out what