aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 44d1df2848..ae69b470e9 100644
--- a/configure.in
+++ b/configure.in
@@ -66,8 +66,12 @@ AC_ARG_WITH(elf, dnl
--with-elf if using the ELF object format,
elf=$withval, elf=no)
AC_ARG_WITH(cvs, dnl
-[ --without-cvs if CVS should not be used],
+[ --without-cvs if CVS should not be used],
with_cvs=$withval, with_cvs=yes)
+if test "$with_cvs" = yes && test -d CVS && grep :pserver: CVS/Root > /dev/null
+then
+ with_cvs=no
+fi
AC_SUBST(with_cvs)
AC_ARG_WITH(headers, dnl