aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 63e2da2a6d..7593aa611c 100644
--- a/configure.in
+++ b/configure.in
@@ -304,6 +304,16 @@ if test -z "$enable_hacker_mode"; then
esac
fi
+# Brain dead PowerPC box with absolutely no FPU.
+echo $host
+case "$machine-$host_os" in
+ powerpc*-*soft)
+ with_fp=no
+ completely_soft=yes
+ AC_SUBST(completely_soft)
+ ;;
+esac
+
dnl We need to use [ and ] for other purposes for a while now.
changequote(,)dnl
# Expand the configuration machine name into a subdirectory by architecture