aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.de>2001-08-09 10:51:51 +0000
committerAndreas Jaeger <aj@suse.de>2001-08-09 10:51:51 +0000
commitb649a605f780246f16f75d4f95267d87eabde1d5 (patch)
treee10b6a84dea47c74fb91c733bcb6d8cc8520d89f /configure.in
parent40a982a9e1b825b175be7bc7c7199c6bdf363e4b (diff)
downloadglibc-b649a605f780246f16f75d4f95267d87eabde1d5.tar
glibc-b649a605f780246f16f75d4f95267d87eabde1d5.tar.gz
glibc-b649a605f780246f16f75d4f95267d87eabde1d5.tar.bz2
glibc-b649a605f780246f16f75d4f95267d87eabde1d5.zip
* configure.in: Add check for GCC 3.x.
2001-08-09 Andreas Jaeger <aj@suse.de> * configure.in: Add check for GCC 3.x.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 177e3e4abf..5962b91340 100644
--- a/configure.in
+++ b/configure.in
@@ -636,6 +636,27 @@ test -n "$aux_missing" && AC_MSG_WARN([
CCVERSION=`$CC -v 2>&1 | sed -n 's/gcc version //p'`
AC_SUBST(CCVERSION)
+case $CCVERSION in
+ 3.*) gcc3=yes;;
+esac
+
+if test x"$gcc3" = xyes; then
+ echo "\
+*** This version of GNU libc cannot be compiled by GCC 3.x.
+*** GCC 3.x will generate a library that is binary incompatible to
+*** older and future releases of GNU libc.
+*** You should compile this GNU libc release by an older GCC version
+*** or wait for the next GNU libc release."
+ if test $enable_sanity = yes; then
+ echo "\
+*** If you really mean to use GCC 3.x, run configure again
+*** using the extra parameter \`--disable-sanity-checks'."
+ exit 1
+ else
+ echo "\
+*** This configuration is not supported by the GNU libc developers."
+ fi
+fi
# if using special system headers, find out the compiler's sekrit
# header directory and add that to the list. NOTE: Only does the right
# thing on a system that doesn't need fixincludes. (Not presently a problem.)