aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2020-05-18 14:56:26 +0200
committerFlorian Weimer <fweimer@redhat.com>2020-05-18 15:39:34 +0200
commitce12fc711387375d0248ab3ff9084fb958c43bc6 (patch)
tree209238fe57d7638b79a7c112fe8c2192256e0324 /configure.ac
parent7b5bfe77836442b9aeb75cc520f0d1eb7f82be67 (diff)
downloadglibc-ce12fc711387375d0248ab3ff9084fb958c43bc6.tar
glibc-ce12fc711387375d0248ab3ff9084fb958c43bc6.tar.gz
glibc-ce12fc711387375d0248ab3ff9084fb958c43bc6.tar.bz2
glibc-ce12fc711387375d0248ab3ff9084fb958c43bc6.zip
Remove NO_CTORS_DTORS_SECTIONS macro
This was originally added to support binutils older than version 2.22: <https://sourceware.org/ml/libc-alpha/2010-12/msg00051.html> Since 2.22 is older than the minimum required binutils version for building glibc, we no longer need this. (The changes do not impact the statically linked startup code.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 0 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index 5f229679a9..ff00591fd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1251,36 +1251,6 @@ if test $libc_cv_have_sdata_section = yes; then
AC_DEFINE(HAVE_SDATA_SECTION)
fi
-AC_CACHE_CHECK(whether to use .ctors/.dtors header and trailer,
- libc_cv_ctors_header, [dnl
- libc_cv_ctors_header=yes
- LIBC_TRY_LINK_STATIC([
-__attribute__ ((constructor)) void ctor (void) { asm (""); }
-__attribute__ ((destructor)) void dtor (void) { asm (""); }
-],
- [dnl
- AS_IF([$READELF -WS conftest$ac_exeext | $AWK '
- { gsub(/\@<:@ */, "@<:@") }
- $2 == ".ctors" || $2 == ".dtors" {
- size = strtonum("0x" $6)
- align = strtonum("0x" $NF)
- seen@<:@$2@:>@ = 1
- stub@<:@$2@:>@ = size == align * 2
- }
- END {
- ctors_ok = !seen@<:@".ctors"@:>@ || stub@<:@".ctors"@:>@
- dtors_ok = !seen@<:@".dtors"@:>@ || stub@<:@".dtors"@:>@
- exit ((ctors_ok && dtors_ok) ? 0 : 1)
- }
- '], [libc_cv_ctors_header=no])
- ], [dnl
- AC_MSG_ERROR([missing __attribute__ ((constructor)) support??])
- ])
-])
-if test $libc_cv_ctors_header = no; then
- AC_DEFINE(NO_CTORS_DTORS_SECTIONS)
-fi
-
AC_CACHE_CHECK(for libunwind-support in compiler,
libc_cv_cc_with_libunwind, [
cat > conftest.c <<EOF