aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Vorel <pvorel@suse.cz>2020-07-08 13:06:55 +0200
committerFlorian Weimer <fweimer@redhat.com>2020-07-08 17:25:57 +0200
commitae7a94e5e3edf78f4da562edc05ece229614c716 (patch)
treebe0969c61080fc1dbd69293944a3362b20db7cff /configure.ac
parentacb527929d0c2b3bb0798472c42ddb3203729708 (diff)
downloadglibc-ae7a94e5e3edf78f4da562edc05ece229614c716.tar
glibc-ae7a94e5e3edf78f4da562edc05ece229614c716.tar.gz
glibc-ae7a94e5e3edf78f4da562edc05ece229614c716.tar.bz2
glibc-ae7a94e5e3edf78f4da562edc05ece229614c716.zip
Remove --enable-obsolete-nsl configure flag
this means that *always* libnsl is only built as shared library for backward compatibility and the NSS modules libnss_nis and libnss_nisplus are not built at all, libnsl's headers aren't installed. This compatibility is kept only for architectures and ABIs that have been added in or before version 2.28. Replacement implementations based on TIRPC, which additionally support IPv6, are available from <https://github.com/thkukuk/>. This change does not affect libnss_compat which does not depended on libnsl since 2.27 and thus can be used without NIS. libnsl code depends on Sun RPC, e.g. on --enable-obsolete-rpc (installed libnsl headers use installed Sun RPC headers), which will be removed in the following commit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index ff00591fd4..33a1189804 100644
--- a/configure.ac
+++ b/configure.ac
@@ -387,17 +387,6 @@ if test "$link_obsolete_rpc" = yes; then
AC_DEFINE(LINK_OBSOLETE_RPC)
fi
-AC_ARG_ENABLE([obsolete-nsl],
- AC_HELP_STRING([--enable-obsolete-nsl],
- [build and install the obsolete libnsl library and depending NSS modules]),
- [build_obsolete_nsl=$enableval],
- [build_obsolete_nsl=no])
-AC_SUBST(build_obsolete_nsl)
-
-if test "$build_obsolete_nsl" = yes; then
- AC_DEFINE(LINK_OBSOLETE_NSL)
-fi
-
AC_ARG_ENABLE([systemtap],
[AS_HELP_STRING([--enable-systemtap],
[enable systemtap static probe points @<:@default=no@:>@])],