aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a80788b..b43956c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,10 +12,13 @@ sshfs_CFLAGS = $(SSHFS_CFLAGS)
sshfs_CPPFLAGS = -D_REENTRANT -DFUSE_USE_VERSION=26 -DLIBDIR=\"$(libdir)\"
EXTRA_DIST = sshnodelay.c FAQ.txt
-CLEANFILES = sshnodelay.so
+CLEANFILES = sshnodelay.so sshfs.1
dist_man_MANS = sshfs.1
+sshfs.1:
+ $(CPP) $(CPPFLAGS) -P -xassembler-with-cpp sshfs.1.in | sed -e '/^$$/d' > sshfs.1
+
if SSH_NODELAY_SO
all-local: sshnodelay.so