aboutsummaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2017-06-20 13:53:55 -0700
committerNikolaus Rath <Nikolaus@rath.org>2017-07-12 17:10:18 +0200
commit4828a8a59cec58bb4a6f1d4c1552c62a45f12a26 (patch)
tree6cb1b8a17fa1c5f255c1a1378e7136291a51a8c6 /test/meson.build
parent7ad9156d4df999df162c005eb6cdeba3f31bbb25 (diff)
downloadsshfs-4828a8a59cec58bb4a6f1d4c1552c62a45f12a26.tar
sshfs-4828a8a59cec58bb4a6f1d4c1552c62a45f12a26.tar.gz
sshfs-4828a8a59cec58bb4a6f1d4c1552c62a45f12a26.tar.bz2
sshfs-4828a8a59cec58bb4a6f1d4c1552c62a45f12a26.zip
Added unit tests and travis integration
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
new file mode 100644
index 0000000..90eb94e
--- /dev/null
+++ b/test/meson.build
@@ -0,0 +1,11 @@
+test_scripts = [ 'conftest.py', 'pytest.ini', 'test_sshfs.py',
+ 'util.py' ]
+custom_target('test_scripts', input: test_scripts,
+ output: test_scripts, build_by_default: true,
+ command: ['cp', '-fPu', '--preserve=mode',
+ '@INPUT@', meson.current_build_dir() ])
+
+# Provide something helpful when running 'ninja test'
+wrong_cmd = executable('wrong_command', 'wrong_command.c',
+ install: false)
+test('wrong_cmd', wrong_cmd)