aboutsummaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2017-06-20 13:53:55 -0700
committerNikolaus Rath <Nikolaus@rath.org>2017-06-22 14:22:57 -0700
commit5f4619bac33a544af4da6e7d28bb4d7dbe45ae92 (patch)
treeab79661111460b9aab6a7b9452dfcf52a59a90de /test/meson.build
parentb66ecb9c3a1d4a7756ad48c61a8b2e82b08f1e8c (diff)
downloadsshfs-5f4619bac33a544af4da6e7d28bb4d7dbe45ae92.tar
sshfs-5f4619bac33a544af4da6e7d28bb4d7dbe45ae92.tar.gz
sshfs-5f4619bac33a544af4da6e7d28bb4d7dbe45ae92.tar.bz2
sshfs-5f4619bac33a544af4da6e7d28bb4d7dbe45ae92.zip
Added unit tests and travis integration
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
new file mode 100644
index 0000000..90eb94e
--- /dev/null
+++ b/test/meson.build
@@ -0,0 +1,11 @@
+test_scripts = [ 'conftest.py', 'pytest.ini', 'test_sshfs.py',
+ 'util.py' ]
+custom_target('test_scripts', input: test_scripts,
+ output: test_scripts, build_by_default: true,
+ command: ['cp', '-fPu', '--preserve=mode',
+ '@INPUT@', meson.current_build_dir() ])
+
+# Provide something helpful when running 'ninja test'
+wrong_cmd = executable('wrong_command', 'wrong_command.c',
+ install: false)
+test('wrong_cmd', wrong_cmd)