aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2017-06-22 13:56:16 -0700
committerNikolaus Rath <Nikolaus@rath.org>2017-07-12 17:10:18 +0200
commit7ad9156d4df999df162c005eb6cdeba3f31bbb25 (patch)
treec87b37b393a7fba2f7d2bb4269cda1c2be70e54c /meson.build
parentb13abaef128ff5a586066a1ad492ee2bad519a10 (diff)
downloadsshfs-7ad9156d4df999df162c005eb6cdeba3f31bbb25.tar
sshfs-7ad9156d4df999df162c005eb6cdeba3f31bbb25.tar.gz
sshfs-7ad9156d4df999df162c005eb6cdeba3f31bbb25.tar.bz2
sshfs-7ad9156d4df999df162c005eb6cdeba3f31bbb25.zip
Fix Meson manpage install
Without this, Meson is looking for sshfs.1 in the source directory. However, since that is a generated file it is in the build directory.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3f82201..3bc9f14 100644
--- a/meson.build
+++ b/meson.build
@@ -56,4 +56,6 @@ executable('sshfs', sshfs_sources,
install: true,
install_dir: get_option('bindir'))
-install_man('sshfs.1')
+# This is a little ugly. Is there a better way to tell Meson that the
+# manpage is in the build directory?
+install_man(join_paths(meson.current_build_dir(), 'sshfs.1'))