aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulio Merino <jmmv@google.com>2016-02-08 11:34:04 -0500
committerJulio Merino <jmmv@meroh.net>2016-02-08 20:46:45 -0500
commit3bf3be3bcd0855f1fb90e9df23eeaf597e98f34a (patch)
tree19f55fed0b1ef89f3670af985953c67ecfd94c08 /configure.ac
parentddbe3bee444909420049a68f7891563f0e431669 (diff)
downloadsshfs-3bf3be3bcd0855f1fb90e9df23eeaf597e98f34a.tar
sshfs-3bf3be3bcd0855f1fb90e9df23eeaf597e98f34a.tar.gz
sshfs-3bf3be3bcd0855f1fb90e9df23eeaf597e98f34a.tar.bz2
sshfs-3bf3be3bcd0855f1fb90e9df23eeaf597e98f34a.zip
Rename arch to osname
Operating system names are not architectures; therefore, rename the arch variable to osname to better represent its contents. While doing this, drop a bunch of unused values from the osname.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index d0ee2eb..7b4a13f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,12 +12,10 @@ sshnodelay_libs=$LIBS
AC_SUBST(sshnodelay_libs)
LIBS=
-case $target_os in
- *linux*) arch=linux;;
- *netbsd*) arch=netbsd;;
- *bsd*) arch=bsd;;
- *darwin*) arch=darwin;;
- *) arch=unknown;;
+case "$target_os" in
+ *linux*) osname=linux;;
+ *darwin*) osname=darwin;;
+ *) osname=unknown;;
esac
AC_ARG_ENABLE(sshnodelay,
@@ -52,11 +50,11 @@ oldlibs="$LIBS"
LIBS="$LIBS $SSHFS_LIBS"
AC_CHECK_FUNC([fuse_opt_parse], [have_fuse_opt_parse=yes])
LIBS="$oldlibs"
-if test "$have_fuse_opt_parse" = no -o "$arch" = darwin; then
+if test "$have_fuse_opt_parse" = no -o "$osname" = darwin; then
CFLAGS="$CFLAGS -Icompat"
fi
AM_CONDITIONAL(FUSE_OPT_COMPAT, test "$have_fuse_opt_parse" = no)
-AM_CONDITIONAL(DARWIN_COMPAT, test "$arch" = darwin)
+AM_CONDITIONAL(DARWIN_COMPAT, test "$osname" = darwin)
AC_CONFIG_FILES([Makefile])
AC_OUTPUT