aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulio Merino <jmmv@google.com>2016-02-08 11:12:22 -0500
committerJulio Merino <jmmv@meroh.net>2016-02-08 20:46:37 -0500
commitddbe3bee444909420049a68f7891563f0e431669 (patch)
tree1273577a0fd0fa7ce54b426688938b785b442666 /configure.ac
parentb10d21db3185a2b25e3bd35579f57d3c7b8d882e (diff)
parent9bcb98945405db3d64cd8dca409aa18990ff1929 (diff)
downloadsshfs-ddbe3bee444909420049a68f7891563f0e431669.tar
sshfs-ddbe3bee444909420049a68f7891563f0e431669.tar.gz
sshfs-ddbe3bee444909420049a68f7891563f0e431669.tar.bz2
sshfs-ddbe3bee444909420049a68f7891563f0e431669.zip
Merge remote-tracking branch 'osxfuse/master' into merge-osxfuse
Pull in all changes from osxfuse's fork of sshfs into libfuse's sshfs. There need not be two different copies of this codebase, particularly because libfuse's version is already autoconf-ified and can support multiple platforms. The merge is mostly clean with just a few manual edits to resolve conflicts.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4d7e23c..d0ee2eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,5 @@
AC_INIT(sshfs, 2.6)
+AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE([foreign subdir-objects])
AM_CONFIG_HEADER(config.h)
@@ -11,6 +12,14 @@ sshnodelay_libs=$LIBS
AC_SUBST(sshnodelay_libs)
LIBS=
+case $target_os in
+ *linux*) arch=linux;;
+ *netbsd*) arch=netbsd;;
+ *bsd*) arch=bsd;;
+ *darwin*) arch=darwin;;
+ *) arch=unknown;;
+esac
+
AC_ARG_ENABLE(sshnodelay,
[ --disable-sshnodelay Don't compile NODELAY workaround for ssh])
@@ -43,10 +52,11 @@ oldlibs="$LIBS"
LIBS="$LIBS $SSHFS_LIBS"
AC_CHECK_FUNC([fuse_opt_parse], [have_fuse_opt_parse=yes])
LIBS="$oldlibs"
-if test "$have_fuse_opt_parse" = no; then
+if test "$have_fuse_opt_parse" = no -o "$arch" = darwin; then
CFLAGS="$CFLAGS -Icompat"
fi
AM_CONDITIONAL(FUSE_OPT_COMPAT, test "$have_fuse_opt_parse" = no)
+AM_CONDITIONAL(DARWIN_COMPAT, test "$arch" = darwin)
AC_CONFIG_FILES([Makefile])
AC_OUTPUT