aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulio Merino <jmmv@meroh.net>2016-02-08 20:48:45 -0500
committerJulio Merino <jmmv@meroh.net>2016-02-08 20:50:23 -0500
commita03d3eab39b265fb9fcb5287d81061e7957f355a (patch)
treecaad46354c7460d4b59d64bcb03d22d00ea646f9 /configure.ac
parent665bb97ef616e4de9c501f74db83f6ebc0ddc72a (diff)
downloadsshfs-a03d3eab39b265fb9fcb5287d81061e7957f355a.tar
sshfs-a03d3eab39b265fb9fcb5287d81061e7957f355a.tar.gz
sshfs-a03d3eab39b265fb9fcb5287d81061e7957f355a.tar.bz2
sshfs-a03d3eab39b265fb9fcb5287d81061e7957f355a.zip
Fix path to compat in -I flag
When defining a -I flag to point into the source directory, we should prefix the directory with ${srcdir} so that it can be found when the build is configured to use a build directory that differs from the source directory. This fixes "make distcheck".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7b4a13f..7fdc36a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,7 @@ LIBS="$LIBS $SSHFS_LIBS"
AC_CHECK_FUNC([fuse_opt_parse], [have_fuse_opt_parse=yes])
LIBS="$oldlibs"
if test "$have_fuse_opt_parse" = no -o "$osname" = darwin; then
- CFLAGS="$CFLAGS -Icompat"
+ CFLAGS="$CFLAGS -I${srcdir}/compat"
fi
AM_CONDITIONAL(FUSE_OPT_COMPAT, test "$have_fuse_opt_parse" = no)
AM_CONDITIONAL(DARWIN_COMPAT, test "$osname" = darwin)