aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulio Merino <jmmv@meroh.net>2016-02-08 21:10:48 -0500
committerJulio Merino <jmmv@meroh.net>2016-02-08 21:10:48 -0500
commit9b4ca1aadefbb75ab4051e0b0e9173709456f7fb (patch)
treee7f4f74ed91779bdde639cc35a12a7ab27626334 /configure.ac
parenta03d3eab39b265fb9fcb5287d81061e7957f355a (diff)
downloadsshfs-9b4ca1aadefbb75ab4051e0b0e9173709456f7fb.tar
sshfs-9b4ca1aadefbb75ab4051e0b0e9173709456f7fb.tar.gz
sshfs-9b4ca1aadefbb75ab4051e0b0e9173709456f7fb.tar.bz2
sshfs-9b4ca1aadefbb75ab4051e0b0e9173709456f7fb.zip
Avoid using cpp for sshfs.1 generation
Move the logic to determine which values to stick into the manual page to the configure script and replace the logic to build the sshfs.1 manual page with sed instead of abusing cpp. I'm not using AC_OUTPUT here because this macro is typically used to generate support build files. Final artifacts of the build should, in general, be built by the Makefile itself.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fdc36a..a91ec3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,5 +56,16 @@ fi
AM_CONDITIONAL(FUSE_OPT_COMPAT, test "$have_fuse_opt_parse" = no)
AM_CONDITIONAL(DARWIN_COMPAT, test "$osname" = darwin)
+AC_CHECK_PROG(UNMOUNT_COMMAND, fusermount, fusermount -u, umount)
+
+# TODO: Figure out why we special-case this in Darwin. Would be nice if
+# the default setting was consistent across platforms so we wouldn't need
+# to care about it here.
+case "$osname" in
+ darwin) IDMAP_DEFAULT=user ;;
+ *) IDMAP_DEFAULT=none ;;
+esac
+AC_SUBST(IDMAP_DEFAULT)
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT