aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Szeredi <miklos@szeredi.hu>2006-01-09 16:51:06 +0000
committerMiklos Szeredi <miklos@szeredi.hu>2006-01-09 16:51:06 +0000
commit3f854ace05e48378a522395ed764249b1079e9da (patch)
treec744e3d009b06e3d918fdb22b617a51bd45d326d /configure.ac
parent6a6476b52b064ae082d73d991a7280a11ba1da73 (diff)
downloadsshfs-3f854ace05e48378a522395ed764249b1079e9da.tar
sshfs-3f854ace05e48378a522395ed764249b1079e9da.tar.gz
sshfs-3f854ace05e48378a522395ed764249b1079e9da.tar.bz2
sshfs-3f854ace05e48378a522395ed764249b1079e9da.zip
fix
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 314d00f..6366ec2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,12 @@ export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH
PKG_CHECK_MODULES(SSHFS, [fuse >= 2.2 glib-2.0])
CFLAGS="$CFLAGS -Wall -W -D_REENTRANT $SSHFS_CFLAGS"
LIBS="$SSHFS_LIBS"
+have_fuse_opt_parse=no
+AC_CHECK_FUNC([fuse_opt_parse], [have_fuse_opt_parse=yes])
+if test "$have_fuse_opt_parse" = no; then
+ CFLAGS="$CFLAGS -Icompat"
+fi
+AM_CONDITIONAL(FUSE_OPT_COMPAT, test "$have_fuse_opt_parse" = no)
AC_CONFIG_FILES([Makefile])
AC_OUTPUT