aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2017-06-06 10:57:09 -0400
committerNikolaus Rath <Nikolaus@rath.org>2017-06-06 11:01:21 -0400
commit132dd88755a115e2c44cea1a8c68009e59b994a3 (patch)
tree76e463c8d579c6ccd118bad2be70f6acfe7dee72 /configure.ac
parentaf1f3c6235833ae2500eb886c612a142fd82017c (diff)
downloadsshfs-132dd88755a115e2c44cea1a8c68009e59b994a3.tar
sshfs-132dd88755a115e2c44cea1a8c68009e59b994a3.tar.gz
sshfs-132dd88755a115e2c44cea1a8c68009e59b994a3.tar.bz2
sshfs-132dd88755a115e2c44cea1a8c68009e59b994a3.zip
Dropped nodelay workaround
This was a performance improvement for SSH versions prior to 4.4. There is no reason to continue to support this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index f33bb1b..93af51b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,8 +8,6 @@ AM_PROG_CC_C_O
CFLAGS="$CFLAGS -Wall -W"
LIBS=
AC_SEARCH_LIBS(dlsym, [dl])
-sshnodelay_libs=$LIBS
-AC_SUBST(sshnodelay_libs)
LIBS=
case "$target_os" in
@@ -18,31 +16,6 @@ case "$target_os" in
*) osname=unknown;;
esac
-AC_ARG_ENABLE(sshnodelay,
- [ --disable-sshnodelay Don't compile NODELAY workaround for ssh])
-
-if test -z "$enable_sshnodelay"; then
- AC_MSG_CHECKING([OpenSSH version])
- [eval `ssh -V 2>&1 | sed -n 's/^OpenSSH_\([1-9][0-9]*\)\.\([0-9][0-9]*\).*/ssh_major=\1 ssh_minor=\2/p'`]
- if test "x$ssh_major" != x -a "x$ssh_minor" != x; then
- if test $ssh_major -gt 4 -o \( $ssh_major = 4 -a $ssh_minor -ge 4 \); then
- AC_MSG_RESULT([$ssh_major.$ssh_minor >= 4.4, disabling NODELAY workaround])
- enable_sshnodelay=no
- else
- AC_MSG_RESULT([$ssh_major.$ssh_minor < 4.4, enabling NODELAY workaround])
- enable_sshnodelay=yes
- fi
- else
- AC_MSG_RESULT([not found])
- fi
-fi
-
-if test "$enable_sshnodelay" = "yes"; then
- AC_DEFINE(SSH_NODELAY_WORKAROUND, 1, [Compile ssh NODELAY workaround])
-fi
-
-AM_CONDITIONAL(SSH_NODELAY_SO, test "$enable_sshnodelay" = "yes")
-
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH
PKG_CHECK_MODULES([SSHFS], [fuse >= 2.3 glib-2.0 gthread-2.0])
have_fuse_opt_parse=no