aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJulio Merino <jmmv@google.com>2016-02-08 11:12:22 -0500
committerJulio Merino <jmmv@meroh.net>2016-02-08 20:46:37 -0500
commitddbe3bee444909420049a68f7891563f0e431669 (patch)
tree1273577a0fd0fa7ce54b426688938b785b442666 /Makefile.am
parentb10d21db3185a2b25e3bd35579f57d3c7b8d882e (diff)
parent9bcb98945405db3d64cd8dca409aa18990ff1929 (diff)
downloadsshfs-ddbe3bee444909420049a68f7891563f0e431669.tar
sshfs-ddbe3bee444909420049a68f7891563f0e431669.tar.gz
sshfs-ddbe3bee444909420049a68f7891563f0e431669.tar.bz2
sshfs-ddbe3bee444909420049a68f7891563f0e431669.zip
Merge remote-tracking branch 'osxfuse/master' into merge-osxfuse
Pull in all changes from osxfuse's fork of sshfs into libfuse's sshfs. There need not be two different copies of this codebase, particularly because libfuse's version is already autoconf-ified and can support multiple platforms. The merge is mostly clean with just a few manual edits to resolve conflicts.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e1e5510..c5b92f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,16 +6,22 @@ sshfs_SOURCES = sshfs.c cache.c cache.h
if FUSE_OPT_COMPAT
sshfs_SOURCES += compat/fuse_opt.c compat/fuse_opt.h
endif
+if DARWIN_COMPAT
+sshfs_SOURCES += compat/darwin_compat.c compat/darwin_compat.h
+endif
sshfs_LDADD = $(SSHFS_LIBS)
sshfs_CFLAGS = $(SSHFS_CFLAGS)
sshfs_CPPFLAGS = -D_REENTRANT -DFUSE_USE_VERSION=26 -DLIBDIR=\"$(libdir)\"
EXTRA_DIST = sshnodelay.c
-CLEANFILES = sshnodelay.so
+CLEANFILES = sshnodelay.so sshfs.1
dist_man_MANS = sshfs.1
+sshfs.1:
+ $(CPP) $(CPPFLAGS) -P -xassembler-with-cpp sshfs.1.in | sed -e '/^$$/d' > sshfs.1
+
if SSH_NODELAY_SO
all-local: sshnodelay.so