aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMiklos Szeredi <miklos@szeredi.hu>2006-01-27 12:49:14 +0000
committerMiklos Szeredi <miklos@szeredi.hu>2006-01-27 12:49:14 +0000
commit1cb9aba6ea86e27bf349a7658b36c0daa4a70908 (patch)
tree387f40289b74940078ffc2f4055295e9def15711 /Makefile.am
parent3883b4eb0cedb3d628a1267aa97f023cb0a2b9bd (diff)
downloadsshfs-1cb9aba6ea86e27bf349a7658b36c0daa4a70908.tar
sshfs-1cb9aba6ea86e27bf349a7658b36c0daa4a70908.tar.gz
sshfs-1cb9aba6ea86e27bf349a7658b36c0daa4a70908.tar.bz2
sshfs-1cb9aba6ea86e27bf349a7658b36c0daa4a70908.zip
fix
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dc4befc..8869467 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,9 +2,18 @@
bin_PROGRAMS = sshfs
+sshfs_SOURCES = sshfs.c cache.c cache.h sshnodelay_so.c
if FUSE_OPT_COMPAT
-compat_sources = compat/fuse_opt.c compat/fuse_opt.h
+sshfs_SOURCES += compat/fuse_opt.c compat/fuse_opt.h
endif
-sshfs_SOURCES = sshfs.c cache.c cache.h $(compat_sources)
sshfs_CPPFLAGS = -DFUSE_USE_VERSION=26
+
+EXTRA_DIST = sshnodelay.c bin2c.c
+CLEANFILES = sshnodelay.so sshnodelay_so.c bin2c
+
+sshnodelay_so.c: bin2c sshnodelay.so
+ ./bin2c sshnodelay_so < sshnodelay.so > sshnodelay_so.c
+
+sshnodelay.so:
+ $(CC) -Wall -W -s --shared -ldl sshnodelay.c -o sshnodelay.so