aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Fleischer <fleiben@gmail.com>2012-03-11 16:11:08 +0100
committerBenjamin Fleischer <fleiben@gmail.com>2012-03-11 17:35:25 +0100
commitf4631f0a170b26b4a8364aa8706475f304f5f824 (patch)
tree3f1c57ad7ad3d9f253bac55c26500f4f50f13e69 /Makefile.am
parent3c44e22dddd84f879026829ca37894d861325b77 (diff)
downloadsshfs-f4631f0a170b26b4a8364aa8706475f304f5f824.tar
sshfs-f4631f0a170b26b4a8364aa8706475f304f5f824.tar.gz
sshfs-f4631f0a170b26b4a8364aa8706475f304f5f824.tar.bz2
sshfs-f4631f0a170b26b4a8364aa8706475f304f5f824.zip
Add Darwin/OS X specific information to man page
* Volumes are unmounted using "umount" not "fusermount" * idmap=user is the deafault setting on Darwin/OS X
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a80788b..b43956c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,10 +12,13 @@ sshfs_CFLAGS = $(SSHFS_CFLAGS)
sshfs_CPPFLAGS = -D_REENTRANT -DFUSE_USE_VERSION=26 -DLIBDIR=\"$(libdir)\"
EXTRA_DIST = sshnodelay.c FAQ.txt
-CLEANFILES = sshnodelay.so
+CLEANFILES = sshnodelay.so sshfs.1
dist_man_MANS = sshfs.1
+sshfs.1:
+ $(CPP) $(CPPFLAGS) -P -xassembler-with-cpp sshfs.1.in | sed -e '/^$$/d' > sshfs.1
+
if SSH_NODELAY_SO
all-local: sshnodelay.so