aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMiklos Szeredi <miklos@szeredi.hu>2006-01-31 18:34:38 +0000
committerMiklos Szeredi <miklos@szeredi.hu>2006-01-31 18:34:38 +0000
commit89da93d07eeb3629858011358a4f07ded2f64df0 (patch)
treecfd04a454b32d33f10471f3d8ea4f032eb2ccfd0 /Makefile.am
parentcb4239036ada3acfbf7a425ef9e74d7ace7c9d3a (diff)
downloadsshfs-89da93d07eeb3629858011358a4f07ded2f64df0.tar
sshfs-89da93d07eeb3629858011358a4f07ded2f64df0.tar.gz
sshfs-89da93d07eeb3629858011358a4f07ded2f64df0.tar.bz2
sshfs-89da93d07eeb3629858011358a4f07ded2f64df0.zip
fix
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 13 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 8869467..8c0ca99 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,18 +2,24 @@
bin_PROGRAMS = sshfs
-sshfs_SOURCES = sshfs.c cache.c cache.h sshnodelay_so.c
+sshfs_SOURCES = sshfs.c cache.c cache.h
if FUSE_OPT_COMPAT
sshfs_SOURCES += compat/fuse_opt.c compat/fuse_opt.h
endif
-sshfs_CPPFLAGS = -DFUSE_USE_VERSION=26
+sshfs_CPPFLAGS = -DFUSE_USE_VERSION=26 -DLIBDIR=\"$(libdir)\"
-EXTRA_DIST = sshnodelay.c bin2c.c
-CLEANFILES = sshnodelay.so sshnodelay_so.c bin2c
+EXTRA_DIST = sshnodelay.c
+CLEANFILES = sshnodelay.so
-sshnodelay_so.c: bin2c sshnodelay.so
- ./bin2c sshnodelay_so < sshnodelay.so > sshnodelay_so.c
+all-local: sshnodelay.so
+
+install-exec-local: sshnodelay.so
+ test -z "$(libdir)" || $(mkdir_p) "$(DESTDIR)$(libdir)"
+ $(INSTALL) -m 755 sshnodelay.so "$(DESTDIR)$(libdir)/sshnodelay.so"
+
+uninstall-local:
+ rm -f "$(DESTDIR)$(libdir)/sshnodelay.so"
sshnodelay.so:
- $(CC) -Wall -W -s --shared -ldl sshnodelay.c -o sshnodelay.so
+ $(CC) -Wall -W -s --shared $(sshnodelay_libs) sshnodelay.c -o sshnodelay.so