aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2017-06-06 12:59:03 -0400
committerNikolaus Rath <Nikolaus@rath.org>2017-06-06 16:45:15 -0400
commit6d7ce1607ac7078cb3fcb5f28ae4526a2c19e0f2 (patch)
tree35de02c4b994df971649db3f8481164ad0743f4d /Makefile.am
parent5659d0d2eab6519c57f636410c27699cadd1ccc0 (diff)
downloadsshfs-6d7ce1607ac7078cb3fcb5f28ae4526a2c19e0f2.tar
sshfs-6d7ce1607ac7078cb3fcb5f28ae4526a2c19e0f2.tar.gz
sshfs-6d7ce1607ac7078cb3fcb5f28ae4526a2c19e0f2.tar.bz2
sshfs-6d7ce1607ac7078cb3fcb5f28ae4526a2c19e0f2.zip
Added support for building with Meson.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 72c771e..e34fbb3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,14 +15,14 @@ sshfs_CFLAGS = $(SSHFS_CFLAGS)
sshfs_CPPFLAGS = -D_REENTRANT -DFUSE_USE_VERSION=26 -DLIBDIR=\"$(libdir)\" \
-DIDMAP_DEFAULT="\"$(IDMAP_DEFAULT)\""
-EXTRA_DIST = sshfs.1.in
+EXTRA_DIST = sshfs.1.in meson.build
CLEANFILES = sshfs.1 sshfs.1.tmp
dist_man_MANS = sshfs.1
sshfs.1: sshfs.1.in
$(AM_V_GEN)sed \
- -e 's,__IDMAP_DEFAULT__,$(IDMAP_DEFAULT),g' \
- -e 's,__UNMOUNT_COMMAND__,$(UNMOUNT_COMMAND),g' \
+ -e 's/[@]IDMAP_DEFAULT@/$(IDMAP_DEFAULT)/g' \
+ -e 's/[@]UNMOUNT_COMMAND@/$(UNMOUNT_COMMAND)/g' \
<$(srcdir)/sshfs.1.in >sshfs.1.tmp || exit 1; \
mv sshfs.1.tmp sshfs.1