aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/i386/elf/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysdeps/i386/elf/configure.in')
-rw-r--r--sysdeps/i386/elf/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/sysdeps/i386/elf/configure.in b/sysdeps/i386/elf/configure.in
index d7e1704540..6352e69aa3 100644
--- a/sysdeps/i386/elf/configure.in
+++ b/sysdeps/i386/elf/configure.in
@@ -7,9 +7,11 @@ GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
AC_CACHE_CHECK(for i386 TLS support, libc_cv_386_tls, [dnl
cat > conftest.s <<\EOF
.section ".tdata", "awT", @progbits
+ .globl foo
foo: .long 1
.section ".tbss", "awT", @nobits
- .comm bar,4,4
+ .globl bar
+bar: .skip 4
.text
baz: leal bar@TLSLDM(%ebx), %eax
leal bar@DTPOFF(%eax), %edx