aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e2edb389fd..177e3e4abf 100644
--- a/configure.in
+++ b/configure.in
@@ -65,6 +65,9 @@ AC_ARG_WITH(binutils, dnl
AC_ARG_WITH(elf, dnl
--with-elf if using the ELF object format,
elf=$withval, elf=no)
+AC_ARG_WITH(xcoff, dnl
+ --with-xcoff if using the XCOFF object format,
+ xcoff=$withval, xcoff=no)
AC_ARG_WITH(cvs, dnl
[ --without-cvs if CVS should not be used],
with_cvs=$withval, with_cvs=yes)
@@ -249,6 +252,11 @@ gnu* | linux* | sysv4* | solaris2* | irix6*)
# These systems (almost) always use the ELF format.
elf=yes
;;
+aix*)
+ # These systems are always xcoff
+ xcoff=yes
+ elf=no
+ ;;
esac
machine=$config_machine
@@ -1521,7 +1529,7 @@ AC_SUBST(libc_cv_rootsbindir)
AC_SUBST(use_ldconfig)
AC_SUBST(ldd_rewrite_script)
-AC_SUBST(gnu_ld) AC_SUBST(gnu_as) AC_SUBST(elf)
+AC_SUBST(gnu_ld) AC_SUBST(gnu_as) AC_SUBST(elf) AC_SUBST(xcoff)
if test $gnu_ld = yes; then
AC_DEFINE(HAVE_GNU_LD)
fi
@@ -1531,6 +1539,9 @@ fi
if test $elf = yes; then
AC_DEFINE(HAVE_ELF)
fi
+if test $xcoff = yes; then
+ AC_DEFINE(HAVE_XCOFF)
+fi
AC_SUBST(static)
AC_SUBST(shared)