aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 5e5ba827af..95d7bf377d 100644
--- a/configure.in
+++ b/configure.in
@@ -698,12 +698,13 @@ AC_PROG_CPP
LIBC_PROG_BINUTILS
AC_SUBST(MIG)dnl Needed by sysdeps/mach/configure.in
-# Accept binutils 2.10.1 or newer (and also any ia64 2.9 version)
-# XXX Commented out because it filters out too many good versions.
-# XXX --drepper
-# AC_CHECK_PROG_VER(AS, $AS, --version,
-# [GNU assembler.* \([0-9]*\.[0-9.]*\(-ia64-[0-9]*\)*\)],
-# [2.10.[1-9]* | 2.1[1-9]* | 2.9-ia64-*], AS=: critic_missing=t)
+# Accept binutils 2.13 or newer.
+AC_CHECK_PROG_VER(AS, $AS, --version,
+ [GNU assembler.* \([0-9]*\.[0-9.]*\)],
+ [2.1[3-9]*], AS=: critic_missing=t)
+AC_CHECK_PROG_VER(LD, $LD, --version,
+ [GNU ld.* \([0-9][0-9]*\.[0-9.]*\)],
+ [2.1[3-9]*], LD=: critic_missing=t)
test -n "$aux_missing" && AC_MSG_WARN([
*** These auxiliary programs are missing or incompatible versions:$aux_missing