aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 39bf510d57..14905e6224 100644
--- a/configure.in
+++ b/configure.in
@@ -873,6 +873,21 @@ EOF
AC_DEFINE(HAVE_ASM_POPSECTION_DIRECTIVE)
fi
fi
+ AC_CACHE_CHECK(for .protected and .hidden assembler directive,
+ libc_cv_asm_protected_directive, [dnl
+ cat > conftest.s <<EOF
+.protected foo
+foo:
+.hidden bar
+bar:
+EOF
+ if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.s 1>&AC_FD_CC); then
+ libc_cv_asm_protected_directive=yes
+ else
+ libc_cv_asm_protected_directive=no
+ fi
+ rm -f conftest*])
+ AC_SUBST(libc_cv_asm_protected_directive)
fi
if test $elf != yes; then