aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/x86/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2024-01-03 12:09:23 -0800
committerH.J. Lu <hjl.tools@gmail.com>2024-01-04 06:08:55 -0800
commitbbfb54930cdd85269504a34b362e77a3ac2a207a (patch)
tree1e6790858eae27d2762760ca2a3315db2afa8f17 /sysdeps/x86/configure.ac
parent0d4a2f3576ebd92ca0001645a533bf70289f264e (diff)
downloadglibc-bbfb54930cdd85269504a34b362e77a3ac2a207a.tar
glibc-bbfb54930cdd85269504a34b362e77a3ac2a207a.tar.gz
glibc-bbfb54930cdd85269504a34b362e77a3ac2a207a.tar.bz2
glibc-bbfb54930cdd85269504a34b362e77a3ac2a207a.zip
i386: Ignore --enable-cet
Since shadow stack is only supported for x86-64, ignore --enable-cet for i386. Always setting $(enable-cet) for i386 to "no" to support ifneq ($(enable-cet),no) in x86 Makefiles. We can't use ifeq ($(enable-cet),yes) since $(enable-cet) can be "yes", "no" or "permissive". Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
Diffstat (limited to 'sysdeps/x86/configure.ac')
-rw-r--r--sysdeps/x86/configure.ac43
1 files changed, 0 insertions, 43 deletions
diff --git a/sysdeps/x86/configure.ac b/sysdeps/x86/configure.ac
index c854bc74ca..437a50623b 100644
--- a/sysdeps/x86/configure.ac
+++ b/sysdeps/x86/configure.ac
@@ -1,49 +1,6 @@
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
# Local configure fragment for sysdeps/x86.
-if test $enable_cet != no; then
- # Check if CET can be enabled.
- AC_CACHE_CHECK(whether CET can be enabled,
- libc_cv_x86_cet_available, [dnl
-cat > conftest.c <<EOF
-#if !defined __CET__ || __CET__ != 3
-# error CET isn't available.
-#endif
-EOF
- if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS -fcf-protection -include cet.h conftest.c 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_x86_cet_available=yes
- else
- libc_cv_x86_cet_available=no
- fi
- rm -rf conftest*])
- if test $libc_cv_x86_cet_available != yes; then
- AC_MSG_ERROR([$CC doesn't support CET])
- fi
-fi
-if test $enable_cet != no; then
- # Check if assembler supports CET.
- AC_CACHE_CHECK(whether assembler supports CET,
- libc_cv_x86_cet_as, [dnl
-cat > conftest.s <<EOF
- incsspd %ecx
-EOF
- if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.s -o conftest.o 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_x86_cet_as=yes
- else
- libc_cv_x86_cet_as=no
- fi
- rm -rf conftest*])
- if test $libc_cv_x86_cet_as = no; then
- AC_MSG_ERROR([$AS doesn't support CET])
- fi
-fi
-if test $enable_cet = yes; then
- AC_DEFINE(DEFAULT_DL_X86_CET_CONTROL, cet_elf_property)
-elif test $enable_cet = permissive; then
- AC_DEFINE(DEFAULT_DL_X86_CET_CONTROL, cet_permissive)
-fi
-LIBC_CONFIG_VAR([enable-cet], [$enable_cet])
-
# Check if linker supports x86 ISA level.
AC_CACHE_CHECK([for linker x86 ISA level support],
libc_cv_include_x86_isa_level, [dnl