aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1998-08-21 22:29:58 +0000
committerUlrich Drepper <drepper@redhat.com>1998-08-21 22:29:58 +0000
commit14a44a692041897082ff4f07be9e24ea512f45b2 (patch)
tree42d87d29629bf99b57ae2ea0aaa49cdb8230e04d /sysdeps/unix/sysv/linux/configure.in
parente36b0b570c69bf7846b785aadf8148900229a239 (diff)
downloadglibc-14a44a692041897082ff4f07be9e24ea512f45b2.tar
glibc-14a44a692041897082ff4f07be9e24ea512f45b2.tar.gz
glibc-14a44a692041897082ff4f07be9e24ea512f45b2.tar.bz2
glibc-14a44a692041897082ff4f07be9e24ea512f45b2.zip
Update.
1998-08-12 Andreas Jaeger <aj@arthur.rhein-neckar.de> * sysdeps/unix/sysv/linux/configure.in: Obey --with-headers, document it. * sysdeps/unix/sysv/linux/alpha/configure.in: New file, contains test for recent Linux 2.1.100+ headers.
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.in')
-rw-r--r--sysdeps/unix/sysv/linux/configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.in b/sysdeps/unix/sysv/linux/configure.in
index 2e7e944aa5..535cd8f41d 100644
--- a/sysdeps/unix/sysv/linux/configure.in
+++ b/sysdeps/unix/sysv/linux/configure.in
@@ -10,6 +10,10 @@ test $stdio = default && stdio=libio
inhibit_glue=yes
define([LIBC_LINUX_VERSION],[2.0.10])dnl
+if test -n "$sysheaders"; then
+ OLD_CFLAGS=$CFLAGS
+ CFLAGS="$CFLAGS $SYSINCLUDES"
+fi
define([libc_cv_linuxVER], [libc_cv_linux]patsubst(LIBC_LINUX_VERSION,[\.]))dnl
AC_CACHE_CHECK(installed Linux kernel header files, libc_cv_linuxVER, [dnl
AC_TRY_COMPILE([#include <linux/version.h>],
@@ -27,9 +31,12 @@ The kernel header files are found usually in /usr/include/asm and
/usr/include/linux; make sure these directories use files from
Linux LIBC_LINUX_VERSION or later. This check uses <linux/version.h>, so
make sure that file was built correctly when installing the kernel header
-files.])
+files. To use kernel headers not from /usr/include/linux, use the
+configure option --with-headers.])
+fi
+if test -n "$sysheaders"; then
+ CFLAGS=$OLD_CFLAGS
fi
-
# The Linux filesystem standard prescribes where to place "essential"
# files. I.e., when the installation prefix is "/usr" we have to place
# shared library objects and the configuration files on the root partition