aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/powerpc/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2004-05-28 21:19:35 +0000
committerUlrich Drepper <drepper@redhat.com>2004-05-28 21:19:35 +0000
commitf2bfeadf7200d607606d53ef5e72d301aac1cf58 (patch)
treeb1499ddf047cf6e357864abb417383a4d768fb63 /sysdeps/powerpc/configure.in
parent3dbfd8117c2d109b63e5bec1e4952aab40d19660 (diff)
downloadglibc-f2bfeadf7200d607606d53ef5e72d301aac1cf58.tar
glibc-f2bfeadf7200d607606d53ef5e72d301aac1cf58.tar.gz
glibc-f2bfeadf7200d607606d53ef5e72d301aac1cf58.tar.bz2
glibc-f2bfeadf7200d607606d53ef5e72d301aac1cf58.zip
Update.
2004-05-28 Steven Munroe <sjmunroe@us.ibm.com> * sysdeps/powerpc/powerpc32/fpu/__longjmp-common.S: Add .machine "altivec" to enable VMX instructions. * sysdeps/powerpc/powerpc32/fpu/setjmp-common.S: Likewise. * sysdeps/powerpc/powerpc64/__longjmp-common.S: Likewise. * sysdeps/powerpc/powerpc64/setjmp-common.S: Likewise. * sysdeps/unix/sysv/linux/powerpc/powerpc32/getcontext.S: Likewise. * sysdeps/unix/sysv/linux/powerpc/powerpc32/setcontext.S: Likewise. * sysdeps/unix/sysv/linux/powerpc/powerpc32/swapcontext.S: Likewise. * sysdeps/unix/sysv/linux/powerpc/powerpc64/getcontext.S: Likewise. * sysdeps/unix/sysv/linux/powerpc/powerpc64/setcontext.S: Likewise. * sysdeps/unix/sysv/linux/powerpc/powerpc64/swapcontext.S: Likewise.
Diffstat (limited to 'sysdeps/powerpc/configure.in')
-rw-r--r--sysdeps/powerpc/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/sysdeps/powerpc/configure.in b/sysdeps/powerpc/configure.in
new file mode 100644
index 0000000000..28cc85934d
--- /dev/null
+++ b/sysdeps/powerpc/configure.in
@@ -0,0 +1,21 @@
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+# Local configure fragment for sysdeps/powerpc.
+
+# Accept binutils which knows about ".machine".
+AC_CACHE_CHECK(for .machine support, libc_cv_ppc_machine, [dnl
+cat > conftest.s <<\EOF
+ .machine "altivec"
+ blr
+EOF
+if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.s 1>&AS_MESSAGE_LOG_FD); then
+ libc_cv_ppc_machine=yes
+else
+ libc_cv_ppc_machine=no
+fi
+rm -f conftest*])
+if test $libc_cv_ppc_machine != yes; then
+ AC_MSG_ERROR([
+*** A binutils version which can handle
+*** .machine "altivec"
+*** is needed.])
+fi