aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/ia64/elf/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-11-08 17:11:02 +0000
committerRoland McGrath <roland@gnu.org>2002-11-08 17:11:02 +0000
commite0bc9a8d13290de5328ae49311493246f406e0bd (patch)
treea98ad2b5103a862cd950019e1b998c844df9624c /sysdeps/ia64/elf/configure.in
parentc6481412ff19d5c551aba9330082a19a4a93260f (diff)
downloadglibc-e0bc9a8d13290de5328ae49311493246f406e0bd.tar
glibc-e0bc9a8d13290de5328ae49311493246f406e0bd.tar.gz
glibc-e0bc9a8d13290de5328ae49311493246f406e0bd.tar.bz2
glibc-e0bc9a8d13290de5328ae49311493246f406e0bd.zip
* sysdeps/ia64/elf/configure.in: Add TLS check.
From Ian Wienand <ianw@cse.unsw.edu.au>. * sysdeps/ia64/elf/configure: Regenerated. 2002-11-07 Roland McGrath <roland@redhat.com> * libio/fileops.c (_IO_new_file_overflow): Use INTUSE(_IO_do_write) in place of _IO_new_do_write. [_LIBC] (_IO_do_write): Define as macro for _IO_new_do_write and #undef before versioned_symbol use. * string/test-string.h (test_init): Fill BUF1 and BUF2 with nonzero characters.
Diffstat (limited to 'sysdeps/ia64/elf/configure.in')
-rw-r--r--sysdeps/ia64/elf/configure.in30
1 files changed, 30 insertions, 0 deletions
diff --git a/sysdeps/ia64/elf/configure.in b/sysdeps/ia64/elf/configure.in
index d25d85bf5d..b113579ee0 100644
--- a/sysdeps/ia64/elf/configure.in
+++ b/sysdeps/ia64/elf/configure.in
@@ -1,6 +1,36 @@
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
# Local configure fragment for sysdeps/ia64/elf.
+if test "$usetls" != no; then
+# Check for support of thread-local storage handling in assembler and
+# linker.
+AC_CACHE_CHECK(for ia64 TLS support, libc_cv_ia64_tls, [dnl
+cat > conftest.s <<\EOF
+ .section ".tdata","awT",@progbits
+foo: data8 25
+ .text
+ addl r16 = @ltoff(@dtpmod(foo#)), gp
+ addl r17 = @ltoff(@dtprel(foo#)), gp
+ addl r18 = @ltoff(@tprel(foo#)), gp
+ addl r19 = @dtprel(foo#), gp
+ adds r21 = @dtprel(foo#), r13
+ movl r23 = @dtprel(foo#)
+ addl r20 = @tprel(foo#), gp
+ adds r22 = @tprel(foo#), r13
+ movl r24 = @tprel(foo#)
+EOF
+dnl
+if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.s 1>&AS_MESSAGE_LOG_FD); then
+ libc_cv_ia64_tls=yes
+else
+ libc_cv_ia64_tls=no
+fi
+rm -f conftest*])
+if test $libc_cv_ia64_tls = yes; then
+ AC_DEFINE(HAVE_TLS_SUPPORT)
+fi
+fi
+
dnl It is always possible to access static and hidden symbols in an
dnl position independent way.
AC_DEFINE(PI_STATIC_AND_HIDDEN)