aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/i386/elf/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2002-02-04 06:24:37 +0000
committerUlrich Drepper <drepper@redhat.com>2002-02-04 06:24:37 +0000
commite23f8d206d85154a99c3f91d58a35227a279c479 (patch)
treefb15983a8e4f67b211a5ec08572d07d8a94854d5 /sysdeps/i386/elf/configure.in
parent9710f75d4a4d57fa86f20e011c6dc6e66c590080 (diff)
downloadglibc-e23f8d206d85154a99c3f91d58a35227a279c479.tar
glibc-e23f8d206d85154a99c3f91d58a35227a279c479.tar.gz
glibc-e23f8d206d85154a99c3f91d58a35227a279c479.tar.bz2
glibc-e23f8d206d85154a99c3f91d58a35227a279c479.zip
Update.
2002-02-03 Ulrich Drepper <drepper@redhat.com> * config.h.in: Add HAVE_TLS_SUPPORT. * sysdeps/i386/elf/configure.in: New file.
Diffstat (limited to 'sysdeps/i386/elf/configure.in')
-rw-r--r--sysdeps/i386/elf/configure.in28
1 files changed, 28 insertions, 0 deletions
diff --git a/sysdeps/i386/elf/configure.in b/sysdeps/i386/elf/configure.in
new file mode 100644
index 0000000000..d7e1704540
--- /dev/null
+++ b/sysdeps/i386/elf/configure.in
@@ -0,0 +1,28 @@
+sinclude(./aclocal.m4)dnl Autoconf lossage
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+# Local configure fragment for sysdeps/unix/sysv/linux.
+
+# Check for support of thread-local storage handling in assembler and
+# linker.
+AC_CACHE_CHECK(for i386 TLS support, libc_cv_386_tls, [dnl
+cat > conftest.s <<\EOF
+ .section ".tdata", "awT", @progbits
+foo: .long 1
+ .section ".tbss", "awT", @nobits
+ .comm bar,4,4
+ .text
+baz: leal bar@TLSLDM(%ebx), %eax
+ leal bar@DTPOFF(%eax), %edx
+ subl foo@GOTTPOFF(%edx), %eax
+ subl $bar@TPOFF, %eax
+EOF
+dnl
+if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.s 1>&AC_FD_CC); then
+ libc_cv_386_tls=yes
+else
+ libc_cv_386_tls=no
+fi
+rm -f conftest*])
+if test $libc_cv_386_tls = yes; then
+ AC_DEFINE(HAVE_TLS_SUPPORT)
+fi