aboutsummaryrefslogtreecommitdiff
path: root/sysdeps/hppa/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2004-10-26 01:35:54 +0000
committerRoland McGrath <roland@gnu.org>2004-10-26 01:35:54 +0000
commit62facdf7c5606c93deb90718676537b1520c1513 (patch)
treea4cf627501d108b7f4463807136e93ac43d2ce85 /sysdeps/hppa/configure.in
parent7b53e1fb2789dac52bbaf2e142564b8e1bf832f5 (diff)
downloadglibc-62facdf7c5606c93deb90718676537b1520c1513.tar
glibc-62facdf7c5606c93deb90718676537b1520c1513.tar.gz
glibc-62facdf7c5606c93deb90718676537b1520c1513.tar.bz2
glibc-62facdf7c5606c93deb90718676537b1520c1513.zip
2004-10-25 Roland McGrath <roland@frob.com>
* configure.in (ASM_LINE_SEP): Move this setting to ... * sysdeps/hppa/configure.in: ... here, new file. * sysdeps/hppa/configure: New generated file. * configure: Regenerated.
Diffstat (limited to 'sysdeps/hppa/configure.in')
-rw-r--r--sysdeps/hppa/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/sysdeps/hppa/configure.in b/sysdeps/hppa/configure.in
new file mode 100644
index 0000000000..1ec6780835
--- /dev/null
+++ b/sysdeps/hppa/configure.in
@@ -0,0 +1,22 @@
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+
+dnl The standard hppa assembler uses `;' to start comments and `!'
+dnl as a line separator.
+hppa*linux*)
+AC_CACHE_CHECK(for assembler line separator,
+ libc_cv_asm_line_sep, [dnl
+cat > conftest.s <<EOF
+nop ; is_old_puffin
+EOF
+if AC_TRY_COMMAND(${CC-cc} -c $ASFLAGS conftest.s 1>&AS_MESSAGE_LOG_FD); then
+ libc_cv_asm_line_sep='!'
+else
+ if test -z "$enable_hacker_mode"; then
+ echo "*** You need a newer assembler to compile glibc"
+ rm -f conftest*
+ exit 1
+ fi
+ libc_cv_asm_line_sep=';'
+fi
+rm -f conftest*])
+AC_DEFINE_UNQUOTED(ASM_LINE_SEP, $libc_cv_asm_line_sep)