summaryrefslogtreecommitdiff
path: root/sysdeps/arc/configure.ac
diff options
context:
space:
mode:
authorVineet Gupta <vgupta@synopsys.com>2018-10-23 15:39:50 -0700
committerVineet Gupta <vgupta@synopsys.com>2020-07-10 16:08:45 -0700
commit0be8ae3679570ff9a193615a035fc8074a8c704f (patch)
treeb5924dd11569bd5ca98dbdfc0a448bed440ee478 /sysdeps/arc/configure.ac
parent33ff7b398830522ef5ef39fa3bbd9249944f7404 (diff)
downloadglibc-0be8ae3679570ff9a193615a035fc8074a8c704f.tar
glibc-0be8ae3679570ff9a193615a035fc8074a8c704f.tar.gz
glibc-0be8ae3679570ff9a193615a035fc8074a8c704f.tar.bz2
glibc-0be8ae3679570ff9a193615a035fc8074a8c704f.zip
ARC: Build Infrastructure
Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
Diffstat (limited to 'sysdeps/arc/configure.ac')
-rw-r--r--sysdeps/arc/configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/sysdeps/arc/configure.ac b/sysdeps/arc/configure.ac
new file mode 100644
index 0000000000..cb490e47b3
--- /dev/null
+++ b/sysdeps/arc/configure.ac
@@ -0,0 +1,26 @@
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+# Local configure fragment for sysdeps/arc.
+
+AC_DEFINE(PI_STATIC_AND_HIDDEN)
+libc_cv_have_sdata_section=no
+
+# For ARC, historically ; was used for comments and not newline
+# Later # also got added to comment list, but ; couldn't be switched to
+# canonical newline as there's lots of code out there which will break
+libc_cv_asm_line_sep='`'
+AC_DEFINE_UNQUOTED(ASM_LINE_SEP, $libc_cv_asm_line_sep)
+
+# For big endian ABI, generate a symbol for selecting right dynamic linker
+AC_CACHE_CHECK([for big endian],
+ [libc_cv_arc_be],
+ [AC_EGREP_CPP(yes,[#ifdef __BIG_ENDIAN__
+ yes
+ #endif
+ ], libc_cv_arc_be=yes, libc_cv_arc_be=no)])
+if test $libc_cv_arc_be = yes; then
+ # For shlib-versions.
+ AC_DEFINE(HAVE_ARC_BE)
+ LIBC_CONFIG_VAR([default-abi], [arcbe])
+else
+ LIBC_CONFIG_VAR([default-abi], [arcle])
+fi