aboutsummaryrefslogtreecommitdiff
path: root/ports/sysdeps
diff options
context:
space:
mode:
authorMarcus Shawcroft <marcus.shawcroft@linaro.org>2013-07-05 17:12:46 +0100
committerMarcus Shawcroft <marcus.shawcroft@linaro.org>2013-07-12 11:22:32 +0100
commit39f0b2e91ac8b2a16f2099b4b759708dcbeb6458 (patch)
treec9bcab7813e69727c4c3e1079696f2b08d37b0a2 /ports/sysdeps
parent8ab07407ba4857e0d565288f786a53360b17466b (diff)
downloadglibc-39f0b2e91ac8b2a16f2099b4b759708dcbeb6458.tar
glibc-39f0b2e91ac8b2a16f2099b4b759708dcbeb6458.tar.gz
glibc-39f0b2e91ac8b2a16f2099b4b759708dcbeb6458.tar.bz2
glibc-39f0b2e91ac8b2a16f2099b4b759708dcbeb6458.zip
[AArch64] Adding -funwind-tables to backtrace.c
Diffstat (limited to 'ports/sysdeps')
-rw-r--r--ports/sysdeps/aarch64/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/ports/sysdeps/aarch64/Makefile b/ports/sysdeps/aarch64/Makefile
index ce2cedd52b..5af7a1655e 100644
--- a/ports/sysdeps/aarch64/Makefile
+++ b/ports/sysdeps/aarch64/Makefile
@@ -1,5 +1,9 @@
long-double-fcts = yes
+ifeq ($(subdir),debug)
+CFLAGS-backtrace.c += -funwind-tables
+endif
+
ifeq ($(subdir),elf)
sysdep-dl-routines += tlsdesc dl-tlsdesc
sysdep_routines += tlsdesc dl-tlsdesc