aboutsummaryrefslogtreecommitdiff
path: root/ports/sysdeps/hppa
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2013-06-05 20:26:40 +0000
committerJoseph Myers <joseph@codesourcery.com>2013-06-05 20:26:40 +0000
commit5556231db2301917cd14a7450de4eba2368c9763 (patch)
tree2456b4a2ec7e4377c420b2f94285dddb53784e5f /ports/sysdeps/hppa
parent869378a5bf1d415f52c14d9697b886d8143a73e1 (diff)
downloadglibc-5556231db2301917cd14a7450de4eba2368c9763.tar
glibc-5556231db2301917cd14a7450de4eba2368c9763.tar.gz
glibc-5556231db2301917cd14a7450de4eba2368c9763.tar.bz2
glibc-5556231db2301917cd14a7450de4eba2368c9763.zip
Remove trailing whitespace in ports.
Diffstat (limited to 'ports/sysdeps/hppa')
-rw-r--r--ports/sysdeps/hppa/configure.in6
-rw-r--r--ports/sysdeps/hppa/dl-fptr.c2
-rw-r--r--ports/sysdeps/hppa/dl-fptr.h2
-rw-r--r--ports/sysdeps/hppa/dl-irel.h2
-rw-r--r--ports/sysdeps/hppa/dl-trampoline.S22
-rw-r--r--ports/sysdeps/hppa/fpu/bits/fenv.h2
-rw-r--r--ports/sysdeps/hppa/fpu/fedisblxcpt.c2
-rw-r--r--ports/sysdeps/hppa/fpu/fegetenv.c2
-rw-r--r--ports/sysdeps/hppa/fpu/fegetexcept.c2
-rw-r--r--ports/sysdeps/hppa/fpu/feholdexcpt.c2
-rw-r--r--ports/sysdeps/hppa/fpu/fesetenv.c2
-rw-r--r--ports/sysdeps/hppa/fpu/fesetround.c2
-rw-r--r--ports/sysdeps/hppa/fpu/feupdateenv.c4
-rw-r--r--ports/sysdeps/hppa/fpu/fgetexcptflg.c4
-rw-r--r--ports/sysdeps/hppa/fpu/fraiseexcpt.c4
-rw-r--r--ports/sysdeps/hppa/fpu/ftestexcept.c4
-rw-r--r--ports/sysdeps/hppa/hppa1.1/addmul_1.S8
-rw-r--r--ports/sysdeps/hppa/hppa1.1/mul_1.S8
-rw-r--r--ports/sysdeps/hppa/hppa1.1/submul_1.S8
-rw-r--r--ports/sysdeps/hppa/hppa1.1/udiv_qrnnd.S8
-rw-r--r--ports/sysdeps/hppa/nptl/pthread_spin_init.c2
-rw-r--r--ports/sysdeps/hppa/nptl/pthread_spin_unlock.c2
-rw-r--r--ports/sysdeps/hppa/nptl/tls.h2
-rw-r--r--ports/sysdeps/hppa/rshift.S2
-rw-r--r--ports/sysdeps/hppa/start.S8
-rw-r--r--ports/sysdeps/hppa/sysdep.h4
26 files changed, 58 insertions, 58 deletions
diff --git a/ports/sysdeps/hppa/configure.in b/ports/sysdeps/hppa/configure.in
index 57cb941bef..40f33603e3 100644
--- a/ports/sysdeps/hppa/configure.in
+++ b/ports/sysdeps/hppa/configure.in
@@ -26,11 +26,11 @@ AC_CACHE_CHECK(for hppa TLS support, libc_cv_hppa_tls, [dnl
cat > conftest.s <<\EOF
; Setup tls data
.section ".tdata","awT",@progbits
-foo: .data 32
+foo: .data 32
.text
; Test general dyanmic relocations
test0:
- addil LT'foo-$tls_gdidx$, %r19
+ addil LT'foo-$tls_gdidx$, %r19
ldo RT'foo-$tls_gdidx$(%r1), %r26
b __tls_get_addr
nop
@@ -50,7 +50,7 @@ test2:
; Test local exec relocations
test3:
mfctl %cr27, %r26
- addil LR'foo-$tls_leoff$, %r26
+ addil LR'foo-$tls_leoff$, %r26
ldo RR'foo-$tls_leoff$(%r1), %r25
; Done all the TLS tests.
EOF
diff --git a/ports/sysdeps/hppa/dl-fptr.c b/ports/sysdeps/hppa/dl-fptr.c
index 4463148ef3..e0a884237d 100644
--- a/ports/sysdeps/hppa/dl-fptr.c
+++ b/ports/sysdeps/hppa/dl-fptr.c
@@ -99,7 +99,7 @@ new_fdesc_table (struct local *l, size_t *size)
}
/* Must call _dl_fptr_init before using any other function. */
-void
+void
_dl_fptr_init (void)
{
struct local *l;
diff --git a/ports/sysdeps/hppa/dl-fptr.h b/ports/sysdeps/hppa/dl-fptr.h
index d3f8a96165..50a5b2f6dd 100644
--- a/ports/sysdeps/hppa/dl-fptr.h
+++ b/ports/sysdeps/hppa/dl-fptr.h
@@ -26,7 +26,7 @@ extern void _dl_fptr_init (void);
/* There are currently 33 dynamic symbols in ld.so.
ELF_MACHINE_BOOT_FPTR_TABLE_LEN needs to be at least that big. */
-#define ELF_MACHINE_BOOT_FPTR_TABLE_LEN 64
+#define ELF_MACHINE_BOOT_FPTR_TABLE_LEN 64
#define ELF_MACHINE_LOAD_ADDRESS(var, symbol) \
asm ( \
diff --git a/ports/sysdeps/hppa/dl-irel.h b/ports/sysdeps/hppa/dl-irel.h
index 86a58e5824..4607194144 100644
--- a/ports/sysdeps/hppa/dl-irel.h
+++ b/ports/sysdeps/hppa/dl-irel.h
@@ -30,7 +30,7 @@
/* Implement enough to get the build going again. */
#warning "NEED STT_GNU_IFUNC IMPLEMENTATION"
-static inline struct fdesc
+static inline struct fdesc
__attribute ((always_inline))
elf_ifunc_invoke (uintptr_t addr)
{
diff --git a/ports/sysdeps/hppa/dl-trampoline.S b/ports/sysdeps/hppa/dl-trampoline.S
index 4d1d7f433a..7fda14a7cc 100644
--- a/ports/sysdeps/hppa/dl-trampoline.S
+++ b/ports/sysdeps/hppa/dl-trampoline.S
@@ -19,18 +19,18 @@
#include <sysdep.h>
/* This code gets called via the .plt stub, and is used in
- dl-runtime.c to call the `_dl_fixup' function and then redirect
- to the address it returns. `_dl_fixup' takes two arguments, however
- `_dl_profile_fixup' takes a number of parameters for use with
+ dl-runtime.c to call the `_dl_fixup' function and then redirect
+ to the address it returns. `_dl_fixup' takes two arguments, however
+ `_dl_profile_fixup' takes a number of parameters for use with
library auditing (LA).
-
+
WARNING: This template is also used by gcc's __cffc, and expects
that the "bl" for _dl_runtime_resolve exist at a particular offset.
Do not change this template without changing gcc, while the prefix
"bl" should fix everything so gcc finds the right spot, it will
slow down __cffc when it attempts to call fixup to resolve function
descriptor references. Please refer to gcc/gcc/config/pa/fptr.c
-
+
Enter with r19 = reloc offset, r20 = got-8, r21 = fixup ltp. */
/* RELOCATION MARKER: bl to provide gcc's __cffc with fixup loc. */
@@ -136,14 +136,14 @@ _dl_runtime_profile:
stw %r21,-32(%sp) /* PIC register value */
/* Create La_hppa_retval */
- /* -140, lrv_r28
+ /* -140, lrv_r28
-136, lrv_r29
- -132, 4 byte pad
+ -132, 4 byte pad
-128, lr_fr4 (8 bytes) */
/* Create save space for _dl_profile_fixup arguments
- -120, Saved reloc offset
- -116, Saved struct link_map
+ -120, Saved reloc offset
+ -116, Saved struct link_map
-112, *framesizep */
/* Create La_hppa_regs */
@@ -216,7 +216,7 @@ L(nf):
b,n L(cont)
L(cpe):
- /* We are going to call the resolved function, but we have a
+ /* We are going to call the resolved function, but we have a
stack frame in the middle. We use the value of framesize to
guess how much extra frame we need, and how much frame to
copy forward. */
@@ -254,7 +254,7 @@ L(cont):
copy %r1, %sp
/* Arguments to _dl_call_pltexit */
- ldw -116(%sp), %r26 /* (1) got[1] == struct link_map */
+ ldw -116(%sp), %r26 /* (1) got[1] == struct link_map */
ldw -120(%sp), %r25 /* (2) reloc offsets */
ldo -56(%sp), %r24 /* (3) *La_hppa_regs */
ldo -124(%sp), %r23 /* (4) *La_hppa_retval */
diff --git a/ports/sysdeps/hppa/fpu/bits/fenv.h b/ports/sysdeps/hppa/fpu/bits/fenv.h
index 7fd14f12de..edbc9b166d 100644
--- a/ports/sysdeps/hppa/fpu/bits/fenv.h
+++ b/ports/sysdeps/hppa/fpu/bits/fenv.h
@@ -74,7 +74,7 @@ typedef unsigned int fexcept_t;
userspace. This structure is also not correctly aligned ever, in
an ABI error we left out __aligned(8) and subsequently all of our
fenv functions must accept unaligned input, align the input, and
- then use assembly to store fr0. This is a performance hit, but
+ then use assembly to store fr0. This is a performance hit, but
means the ABI is stable. */
typedef struct
{
diff --git a/ports/sysdeps/hppa/fpu/fedisblxcpt.c b/ports/sysdeps/hppa/fpu/fedisblxcpt.c
index de03bc9425..6d80b02099 100644
--- a/ports/sysdeps/hppa/fpu/fedisblxcpt.c
+++ b/ports/sysdeps/hppa/fpu/fedisblxcpt.c
@@ -22,7 +22,7 @@
int
fedisableexcept (int excepts)
{
- union { unsigned long long l; unsigned int sw[2]; } s;
+ union { unsigned long long l; unsigned int sw[2]; } s;
unsigned int old_exc;
/* Get the current status word. */
diff --git a/ports/sysdeps/hppa/fpu/fegetenv.c b/ports/sysdeps/hppa/fpu/fegetenv.c
index 0b1d4a8971..590a1177e9 100644
--- a/ports/sysdeps/hppa/fpu/fegetenv.c
+++ b/ports/sysdeps/hppa/fpu/fegetenv.c
@@ -24,7 +24,7 @@ int
fegetenv (fenv_t *envp)
{
unsigned long long buf[4], *bufptr = buf;
-
+
__asm__ (
"fstd,ma %%fr0,8(%1) \n\t"
"fldd -8(%1),%%fr0 \n\t"
diff --git a/ports/sysdeps/hppa/fpu/fegetexcept.c b/ports/sysdeps/hppa/fpu/fegetexcept.c
index 102a723cb0..181cdb520e 100644
--- a/ports/sysdeps/hppa/fpu/fegetexcept.c
+++ b/ports/sysdeps/hppa/fpu/fegetexcept.c
@@ -25,7 +25,7 @@ fegetexcept (void)
union { unsigned long long l; unsigned int sw[2] } s;
/* Get the current status word. */
- __asm__ ("fstd %%fr0,0(%1) \n\t"
+ __asm__ ("fstd %%fr0,0(%1) \n\t"
"fldd 0(%1),%%fr0 \n\t"
: "=m" (s.l) : "r" (&s.l) : "%r0");
diff --git a/ports/sysdeps/hppa/fpu/feholdexcpt.c b/ports/sysdeps/hppa/fpu/feholdexcpt.c
index 5129f89744..c351fa4e16 100644
--- a/ports/sysdeps/hppa/fpu/feholdexcpt.c
+++ b/ports/sysdeps/hppa/fpu/feholdexcpt.c
@@ -40,7 +40,7 @@ feholdexcept (fenv_t *envp)
/* Now clear all flags */
clear.env.__status_word &= ~(FE_ALL_EXCEPT << 27);
- /* Load the new environment. Note: fr0 must load last to enable T-bit
+ /* Load the new environment. Note: fr0 must load last to enable T-bit
Thus we start bufptr at the end and work backwards */
bufptr = (unsigned long long *)((unsigned int)(clear.buf) + sizeof(unsigned int)*4);
__asm__ (
diff --git a/ports/sysdeps/hppa/fpu/fesetenv.c b/ports/sysdeps/hppa/fpu/fesetenv.c
index fd2794200a..e845b2c8dd 100644
--- a/ports/sysdeps/hppa/fpu/fesetenv.c
+++ b/ports/sysdeps/hppa/fpu/fesetenv.c
@@ -49,7 +49,7 @@ fesetenv (const fenv_t *envp)
| FE_DOWNWARD
| (FE_ALL_EXCEPT << 27)));
- /* Load the new environment. We use bufptr again since the
+ /* Load the new environment. We use bufptr again since the
initial asm has modified the value of the register and here
we take advantage of that to load in reverse order so fr0
is loaded last and T-Bit is enabled. */
diff --git a/ports/sysdeps/hppa/fpu/fesetround.c b/ports/sysdeps/hppa/fpu/fesetround.c
index 8516ff0a7a..89d68814d1 100644
--- a/ports/sysdeps/hppa/fpu/fesetround.c
+++ b/ports/sysdeps/hppa/fpu/fesetround.c
@@ -27,7 +27,7 @@ fesetround (int round)
if (round & ~FE_DOWNWARD)
/* round is not a valid rounding mode. */
return 1;
-
+
/* Get the current status word. */
__asm__ ("fstd %%fr0,0(%1)" : "=m" (s.l) : "r" (&s.l) : "%r0");
s.sw[0] &= ~FE_DOWNWARD;
diff --git a/ports/sysdeps/hppa/fpu/feupdateenv.c b/ports/sysdeps/hppa/fpu/feupdateenv.c
index 20573147cb..ce60dfe7f8 100644
--- a/ports/sysdeps/hppa/fpu/feupdateenv.c
+++ b/ports/sysdeps/hppa/fpu/feupdateenv.c
@@ -26,8 +26,8 @@ feupdateenv (const fenv_t *envp)
union { unsigned long long l; unsigned int sw[2]; } s;
fenv_t temp;
/* Get the current exception status */
- __asm__ ("fstd %%fr0,0(%1) \n\t"
- "fldd 0(%1),%%fr0 \n\t"
+ __asm__ ("fstd %%fr0,0(%1) \n\t"
+ "fldd 0(%1),%%fr0 \n\t"
: "=m" (s.l) : "r" (&s.l));
memcpy(&temp, envp, sizeof(fenv_t));
/* Currently raised exceptions not cleared */
diff --git a/ports/sysdeps/hppa/fpu/fgetexcptflg.c b/ports/sysdeps/hppa/fpu/fgetexcptflg.c
index 87f8db80db..580951e4d1 100644
--- a/ports/sysdeps/hppa/fpu/fgetexcptflg.c
+++ b/ports/sysdeps/hppa/fpu/fgetexcptflg.c
@@ -25,8 +25,8 @@ fegetexceptflag (fexcept_t *flagp, int excepts)
union { unsigned long long l; unsigned int sw[2]; } s;
/* Get the current status word. */
- __asm__ ("fstd %%fr0,0(%1) \n\t"
- "fldd 0(%1),%%fr0 \n\t"
+ __asm__ ("fstd %%fr0,0(%1) \n\t"
+ "fldd 0(%1),%%fr0 \n\t"
: "=m" (s.l) : "r" (&s.l) : "%r0");
*flagp = (s.sw[0] >> 27) & excepts & FE_ALL_EXCEPT;
diff --git a/ports/sysdeps/hppa/fpu/fraiseexcpt.c b/ports/sysdeps/hppa/fpu/fraiseexcpt.c
index 204695c22a..0b55d34390 100644
--- a/ports/sysdeps/hppa/fpu/fraiseexcpt.c
+++ b/ports/sysdeps/hppa/fpu/fraiseexcpt.c
@@ -21,7 +21,7 @@
#include <float.h>
#include <math.h>
-/* Please see section 10,
+/* Please see section 10,
page 10-5 "Delayed Trapping" in the PA-RISC 2.0 Architecture manual */
int
@@ -38,7 +38,7 @@ feraiseexcept (int excepts)
occur. */
/* We use "fldd 0(%%sr0,%%sp),%0" to flush the delayed exception */
-
+
/* First: Invalid exception. */
if (excepts & FE_INVALID)
{
diff --git a/ports/sysdeps/hppa/fpu/ftestexcept.c b/ports/sysdeps/hppa/fpu/ftestexcept.c
index f438fa5e37..bf57879edd 100644
--- a/ports/sysdeps/hppa/fpu/ftestexcept.c
+++ b/ports/sysdeps/hppa/fpu/ftestexcept.c
@@ -25,8 +25,8 @@ fetestexcept (int excepts)
union { unsigned long long l; unsigned int sw[2] } s;
/* Get the current status word. */
- __asm__ ("fstd %%fr0,0(%1) \n\t"
- "fldd 0(%1),%%fr0 \n\t"
+ __asm__ ("fstd %%fr0,0(%1) \n\t"
+ "fldd 0(%1),%%fr0 \n\t"
: "=m" (s.l) : "r" (&s.l));
return (s.sw[0] >> 27) & excepts & FE_ALL_EXCEPT;
diff --git a/ports/sysdeps/hppa/hppa1.1/addmul_1.S b/ports/sysdeps/hppa/hppa1.1/addmul_1.S
index caee4feb22..1434979243 100644
--- a/ports/sysdeps/hppa/hppa1.1/addmul_1.S
+++ b/ports/sysdeps/hppa/hppa1.1/addmul_1.S
@@ -37,7 +37,7 @@
.text
.export __mpn_addmul_1
-__mpn_addmul_1:
+__mpn_addmul_1:
.proc
.callinfo frame=64,no_calls
.entry
@@ -60,7 +60,7 @@ __mpn_addmul_1:
ldw -12(%r30),%r1
;! Main loop
-L$loop:
+L$loop:
ldws 0(%r26),%r29
fldws,ma 4(%r25),%fr5
add %r29,%r20,%r20
@@ -73,7 +73,7 @@ L$loop:
addib,<> -1,%r24,L$loop
ldw -12(%r30),%r1
-L$end:
+L$end:
ldw 0(%r26),%r29
add %r29,%r20,%r20
stws,ma %r20,4(%r26)
@@ -87,7 +87,7 @@ L$end:
bv 0(%r2)
ldo -64(%r30),%r30
-L$just_one_limb:
+L$just_one_limb:
xmpyu %fr4,%fr5,%fr6
ldw 0(%r26),%r29
fstds %fr6,-16(%r30)
diff --git a/ports/sysdeps/hppa/hppa1.1/mul_1.S b/ports/sysdeps/hppa/hppa1.1/mul_1.S
index d20cf75668..ba419fd335 100644
--- a/ports/sysdeps/hppa/hppa1.1/mul_1.S
+++ b/ports/sysdeps/hppa/hppa1.1/mul_1.S
@@ -45,7 +45,7 @@
.text
.export __mpn_mul_1
-__mpn_mul_1:
+__mpn_mul_1:
.proc
.callinfo frame=64,no_calls
.entry
@@ -68,7 +68,7 @@ __mpn_mul_1:
ldw -12(%r30),%r1
;! Main loop
-L$loop:
+L$loop:
fldws,ma 4(%r25),%fr5
stws,ma %r20,4(%r26)
addc %r28,%r1,%r20
@@ -78,7 +78,7 @@ L$loop:
addib,<> -1,%r24,L$loop
ldw -12(%r30),%r1
-L$end:
+L$end:
stws,ma %r20,4(%r26)
addc %r28,%r1,%r20
ldw -16(%r30),%r28
@@ -87,7 +87,7 @@ L$end:
bv 0(%r2)
ldo -64(%r30),%r30
-L$just_one_limb:
+L$just_one_limb:
xmpyu %fr4,%fr5,%fr6
fstds %fr6,-16(%r30)
ldw -16(%r30),%r28
diff --git a/ports/sysdeps/hppa/hppa1.1/submul_1.S b/ports/sysdeps/hppa/hppa1.1/submul_1.S
index 31275a1595..8cd5a634f8 100644
--- a/ports/sysdeps/hppa/hppa1.1/submul_1.S
+++ b/ports/sysdeps/hppa/hppa1.1/submul_1.S
@@ -42,7 +42,7 @@
.text
.export __mpn_submul_1
-__mpn_submul_1:
+__mpn_submul_1:
.proc
.callinfo frame=64,no_calls
.entry
@@ -65,7 +65,7 @@ __mpn_submul_1:
ldw -12(%r30),%r1
;! Main loop
-L$loop:
+L$loop:
ldws 0(%r26),%r29
fldws,ma 4(%r25),%fr5
sub %r29,%r20,%r22
@@ -79,7 +79,7 @@ L$loop:
addib,<> -1,%r24,L$loop
ldw -12(%r30),%r1
-L$end:
+L$end:
ldw 0(%r26),%r29
sub %r29,%r20,%r22
add %r22,%r20,%r0
@@ -95,7 +95,7 @@ L$end:
bv 0(%r2)
ldo -64(%r30),%r30
-L$just_one_limb:
+L$just_one_limb:
xmpyu %fr4,%fr5,%fr6
ldw 0(%r26),%r29
fstds %fr6,-16(%r30)
diff --git a/ports/sysdeps/hppa/hppa1.1/udiv_qrnnd.S b/ports/sysdeps/hppa/hppa1.1/udiv_qrnnd.S
index 33d6efce44..c7fa30f349 100644
--- a/ports/sysdeps/hppa/hppa1.1/udiv_qrnnd.S
+++ b/ports/sysdeps/hppa/hppa1.1/udiv_qrnnd.S
@@ -27,11 +27,11 @@
;! d gr23
.text
-L$0000:
+L$0000:
.word 0x43f00000
.word 0x0
.export __udiv_qrnnd
-__udiv_qrnnd:
+__udiv_qrnnd:
.proc
.callinfo frame=64,no_calls
.entry
@@ -48,7 +48,7 @@ L$0:
fcnvxf,dbl,dbl %fr5,%fr5
fldds 0(%r1),%fr4
fadd,dbl %fr4,%fr5,%fr5
-L$1:
+L$1:
fcpy,sgl %fr0,%fr6L
fldws -12(%r30),%fr6R
fcnvxf,dbl,dbl %fr6,%fr4
@@ -69,7 +69,7 @@ L$1:
add %r22,%r23,%r22
ldo -1(%r28),%r28
-L$2:
+L$2:
bv 0(%r2)
stws %r22,0(%r26)
diff --git a/ports/sysdeps/hppa/nptl/pthread_spin_init.c b/ports/sysdeps/hppa/nptl/pthread_spin_init.c
index df3dc4c2ef..c46e00cc89 100644
--- a/ports/sysdeps/hppa/nptl/pthread_spin_init.c
+++ b/ports/sysdeps/hppa/nptl/pthread_spin_init.c
@@ -23,6 +23,6 @@ pthread_spin_init (pthread_spinlock_t *lock, int pshared)
int tmp = 0;
/* This should be a memory barrier to newer compilers */
__asm__ __volatile__ ("stw,ma %1,0(%0)"
- : : "r" (lock), "r" (tmp) : "memory");
+ : : "r" (lock), "r" (tmp) : "memory");
return 0;
}
diff --git a/ports/sysdeps/hppa/nptl/pthread_spin_unlock.c b/ports/sysdeps/hppa/nptl/pthread_spin_unlock.c
index f256a66f1d..6b9d79c7b2 100644
--- a/ports/sysdeps/hppa/nptl/pthread_spin_unlock.c
+++ b/ports/sysdeps/hppa/nptl/pthread_spin_unlock.c
@@ -23,6 +23,6 @@ pthread_spin_unlock (pthread_spinlock_t *lock)
int tmp = 0;
/* This should be a memory barrier to newer compilers */
__asm__ __volatile__ ("stw,ma %1,0(%0)"
- : : "r" (lock), "r" (tmp) : "memory");
+ : : "r" (lock), "r" (tmp) : "memory");
return 0;
}
diff --git a/ports/sysdeps/hppa/nptl/tls.h b/ports/sysdeps/hppa/nptl/tls.h
index fe8d8fc225..14e4705bf0 100644
--- a/ports/sysdeps/hppa/nptl/tls.h
+++ b/ports/sysdeps/hppa/nptl/tls.h
@@ -115,7 +115,7 @@ typedef struct
elf_gregset_t. The thread descriptor is sizeof (struct pthread) away. */
# define DB_THREAD_SELF \
REGISTER (32, 32, 53 * 4, -sizeof (struct pthread))
-
+
/* Access to data in the thread descriptor is easy. */
# define THREAD_GETMEM(descr, member) \
descr->member
diff --git a/ports/sysdeps/hppa/rshift.S b/ports/sysdeps/hppa/rshift.S
index 4356455f26..026fad5af1 100644
--- a/ports/sysdeps/hppa/rshift.S
+++ b/ports/sysdeps/hppa/rshift.S
@@ -1,4 +1,4 @@
-;! HP-PA __mpn_rshift --
+;! HP-PA __mpn_rshift --
;! Copyright (C) 1992-2013 Free Software Foundation, Inc.
diff --git a/ports/sysdeps/hppa/start.S b/ports/sysdeps/hppa/start.S
index 07a490fd24..df8bad8297 100644
--- a/ports/sysdeps/hppa/start.S
+++ b/ports/sysdeps/hppa/start.S
@@ -39,8 +39,8 @@
.import __libc_csu_fini, code
.import __libc_csu_init, code
- /* Have the linker create plabel words so we get PLABEL32
- relocs and not 21/14. The use of 21/14 relocs is only
+ /* Have the linker create plabel words so we get PLABEL32
+ relocs and not 21/14. The use of 21/14 relocs is only
supported in the latest dynamic linker. */
.section .rodata
.align 4
@@ -66,7 +66,7 @@ _start:
r24 - argv
r23 - False _dl_fini plabel address
- This function is called from the lower half of RTLD_START.
+ This function is called from the lower half of RTLD_START.
The call to __libc_start_main expects:
@@ -76,7 +76,7 @@ _start:
4. r23 - __libc_csu_init
5. sp-52 - __libc_csu_fini
6. sp-56 - rtld_fini
- 7. sp-60 - stackend */
+ 7. sp-60 - stackend */
.proc
.callinfo
diff --git a/ports/sysdeps/hppa/sysdep.h b/ports/sysdeps/hppa/sysdep.h
index b7183063b8..7c9edd42a5 100644
--- a/ports/sysdeps/hppa/sysdep.h
+++ b/ports/sysdeps/hppa/sysdep.h
@@ -22,7 +22,7 @@
#include "config.h"
#undef ASM_LINE_SEP
-#define ASM_LINE_SEP !
+#define ASM_LINE_SEP !
#ifdef __ASSEMBLER__
@@ -51,7 +51,7 @@
/* GCC does everything for us. */
#ifdef PROF
-#define CALL_MCOUNT
+#define CALL_MCOUNT
#else
#define CALL_MCOUNT /* Do nothing. */
#endif