aboutsummaryrefslogtreecommitdiff
path: root/ports/sysdeps/arm
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2013-03-11 23:55:55 +0000
committerJoseph Myers <joseph@codesourcery.com>2013-03-11 23:55:55 +0000
commitb7845b638818f32401070f00a61d3b42595ab223 (patch)
tree78cd1c72aac3fb687e386a435223d173796adc17 /ports/sysdeps/arm
parent7f86996afc72481789c01ccc392e542d3318ddc0 (diff)
downloadglibc-b7845b638818f32401070f00a61d3b42595ab223.tar
glibc-b7845b638818f32401070f00a61d3b42595ab223.tar.gz
glibc-b7845b638818f32401070f00a61d3b42595ab223.tar.bz2
glibc-b7845b638818f32401070f00a61d3b42595ab223.zip
Add comments about ARM configure -fno-unwind-tables handling.
Diffstat (limited to 'ports/sysdeps/arm')
-rw-r--r--ports/sysdeps/arm/preconfigure5
-rw-r--r--ports/sysdeps/arm/preconfigure.in5
2 files changed, 10 insertions, 0 deletions
diff --git a/ports/sysdeps/arm/preconfigure b/ports/sysdeps/arm/preconfigure
index 0042aaf240..7ba17492ee 100644
--- a/ports/sysdeps/arm/preconfigure
+++ b/ports/sysdeps/arm/preconfigure
@@ -5,6 +5,11 @@ case "$machine" in
arm*)
case $config_os in
linux-gnueabi*)
+ # If the compiler enables unwind tables by default, this causes
+ # problems with undefined symbols in -nostdlib link tests. To
+ # avoid this, add -fno-unwind-tables here and remove it in
+ # sysdeps/unix/sysv/linux/arm/configure.in after those tests have
+ # been run.
if "${CFLAGS+set}" != "set" ; then
CFLAGS="-g -O2"
fi
diff --git a/ports/sysdeps/arm/preconfigure.in b/ports/sysdeps/arm/preconfigure.in
index f3272f11cd..99f21282fa 100644
--- a/ports/sysdeps/arm/preconfigure.in
+++ b/ports/sysdeps/arm/preconfigure.in
@@ -5,6 +5,11 @@ case "$machine" in
arm*)
case $config_os in
linux-gnueabi*)
+ # If the compiler enables unwind tables by default, this causes
+ # problems with undefined symbols in -nostdlib link tests. To
+ # avoid this, add -fno-unwind-tables here and remove it in
+ # sysdeps/unix/sysv/linux/arm/configure.in after those tests have
+ # been run.
if [ "${CFLAGS+set}" != "set" ]; then
CFLAGS="-g -O2"
fi