aboutsummaryrefslogtreecommitdiff
path: root/nptl/sysdeps/pthread/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2003-03-16 03:22:41 +0000
committerRoland McGrath <roland@gnu.org>2003-03-16 03:22:41 +0000
commiteb64f8cbe3fd1b8e10b1269fa345ea2a0caa976c (patch)
tree7661571a7ea2348d5be1e7aaceb087091fe3903a /nptl/sysdeps/pthread/configure.in
parent385cce415c0060f315b1cbd9260416f54e5853cf (diff)
downloadglibc-eb64f8cbe3fd1b8e10b1269fa345ea2a0caa976c.tar
glibc-eb64f8cbe3fd1b8e10b1269fa345ea2a0caa976c.tar.gz
glibc-eb64f8cbe3fd1b8e10b1269fa345ea2a0caa976c.tar.bz2
glibc-eb64f8cbe3fd1b8e10b1269fa345ea2a0caa976c.zip
* posix/fnmatch_loop.c: Add casts for signedness.
* nscd/nscd_getpw_r.c (nscd_getpw_r): Likewise. * gmon/gmon.c (write_call_graph): Use u_long for FROM_LEN. * nscd/nscd_getgr_r.c (nscd_getgr_r): Use nscd_ssize_t for CNT.
Diffstat (limited to 'nptl/sysdeps/pthread/configure.in')
-rw-r--r--nptl/sysdeps/pthread/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/nptl/sysdeps/pthread/configure.in b/nptl/sysdeps/pthread/configure.in
new file mode 100644
index 0000000000..8350f86dc0
--- /dev/null
+++ b/nptl/sysdeps/pthread/configure.in
@@ -0,0 +1,6 @@
+dnl configure fragment for new libpthread implementation.
+GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
+
+if test "x$libc_cv_gcc___thread" != xyes; then
+ AC_MSG_ERROR(compiler support for __thread is required)
+fi